T-Forum, la vera HiFi alla portata di tutti
Benvenuto nel T-Forum!
Connettiti in modo da farti riconoscere come membro affezionato, oppure registrati così potrai partecipare attivamente alle discussioni.
T-Forum, la vera HiFi alla portata di tutti
Vuoi reagire a questo messaggio? Crea un account in pochi clic o accedi per continuare.

problema music directory con MPD

Andare in basso

problema music directory con MPD Empty problema music directory con MPD

Messaggio Da acvtre il Sab 19 Apr 2014 - 14:57

Ciao a tutti, sto cercando di configurarmi al meglio un music server e così ho installato MPD su SO Xubuntu.
Funziona tutto regolarmente, eccetto il fatto che non riesco a fargli vedere la directory della musica.
In particolare, ho messo il percorso giusto (in teoria), ma quando su mpdroid sullo smartphone faccio "update database" non succede niente.
Come mai? Che posso aver dimenticato?

Sottolineo che la cartella della musica si trova su un hard disk esterno.
acvtre
acvtre
Membro classe bronzo
Membro classe bronzo

Data d'iscrizione : 15.06.09
Numero di messaggi : 1834
Località : Romans d'Isonzo (GO)
Occupazione/Hobby : studente d'ingegneria dei materiali a Trieste
Provincia (Città) : Adelante
Impianto : Sorgente: voyage pc
Dac: ???
Amplificatore: per ora un vecchio sony TA-AX250
Diffusori: linn keilidh (con basi in granito)
Mobile: tnt-flexy autocostruito
Audio portatile: smartphone sony xperia sole, superlux hd381, x-minimax


http://www.myhifi.it/

Torna in alto Andare in basso

problema music directory con MPD Empty Re: problema music directory con MPD

Messaggio Da vds il Sab 19 Apr 2014 - 15:46

@acvtre ha scritto:Ciao a tutti, sto cercando di configurarmi al meglio un music server e così ho installato MPD su SO Xubuntu.
Funziona tutto regolarmente, eccetto il fatto che non riesco a fargli vedere la directory della musica.
In particolare, ho messo il percorso giusto (in teoria), ma quando su mpdroid sullo smartphone faccio "update database" non succede niente.
Come mai? Che posso aver dimenticato?

Sottolineo che la cartella della musica si trova su un hard disk esterno.

Ciao, dando per scontato che il file di configurazione ed il percorso siano corretti, prova a verificare i permessi del directory.
vds
vds
Affezionato
Affezionato

Data d'iscrizione : 01.11.10
Numero di messaggi : 172
Provincia (Città) : TV
Impianto : Chromecast - Denon x3000 - Yamaha p2500s - Cerwin Vega v12F


Torna in alto Andare in basso

problema music directory con MPD Empty Re: problema music directory con MPD

Messaggio Da acvtre il Sab 19 Apr 2014 - 21:23

Ok, ho trovato il problema, l'hard disk esterno non è montato direttamente all'avvio.

Come faccio a montarlo da subito?
acvtre
acvtre
Membro classe bronzo
Membro classe bronzo

Data d'iscrizione : 15.06.09
Numero di messaggi : 1834
Località : Romans d'Isonzo (GO)
Occupazione/Hobby : studente d'ingegneria dei materiali a Trieste
Provincia (Città) : Adelante
Impianto : Sorgente: voyage pc
Dac: ???
Amplificatore: per ora un vecchio sony TA-AX250
Diffusori: linn keilidh (con basi in granito)
Mobile: tnt-flexy autocostruito
Audio portatile: smartphone sony xperia sole, superlux hd381, x-minimax


http://www.myhifi.it/

Torna in alto Andare in basso

problema music directory con MPD Empty Re: problema music directory con MPD

Messaggio Da acvtre il Dom 20 Apr 2014 - 9:01

Ho seguito questa guida: http://guidainstallazionevoyagempdlinux.blogspot.it/2012/06/81-monta-disco-formattato-in-ntfs.html ma il problema non è risolto con mpd. L'hdd risolta montato, ma in compenso non posso smontarlo ed inoltre, l'icona dell'hdd esterno è sparita dal desktop.
acvtre
acvtre
Membro classe bronzo
Membro classe bronzo

Data d'iscrizione : 15.06.09
Numero di messaggi : 1834
Località : Romans d'Isonzo (GO)
Occupazione/Hobby : studente d'ingegneria dei materiali a Trieste
Provincia (Città) : Adelante
Impianto : Sorgente: voyage pc
Dac: ???
Amplificatore: per ora un vecchio sony TA-AX250
Diffusori: linn keilidh (con basi in granito)
Mobile: tnt-flexy autocostruito
Audio portatile: smartphone sony xperia sole, superlux hd381, x-minimax


http://www.myhifi.it/

Torna in alto Andare in basso

problema music directory con MPD Empty Re: problema music directory con MPD

Messaggio Da acvtre il Mar 22 Apr 2014 - 19:30

Alura, ho un nuovo aggiornamento. Funziona tutto eccetto il fatto che devo connettere l'hdd dopo che il pc si è acceso, altrimenti mpd non lo vede.
acvtre
acvtre
Membro classe bronzo
Membro classe bronzo

Data d'iscrizione : 15.06.09
Numero di messaggi : 1834
Località : Romans d'Isonzo (GO)
Occupazione/Hobby : studente d'ingegneria dei materiali a Trieste
Provincia (Città) : Adelante
Impianto : Sorgente: voyage pc
Dac: ???
Amplificatore: per ora un vecchio sony TA-AX250
Diffusori: linn keilidh (con basi in granito)
Mobile: tnt-flexy autocostruito
Audio portatile: smartphone sony xperia sole, superlux hd381, x-minimax


http://www.myhifi.it/

Torna in alto Andare in basso

problema music directory con MPD Empty Re: problema music directory con MPD

Messaggio Da criminale il Mar 22 Apr 2014 - 19:40

@acvtre ha scritto:Alura, ho un nuovo aggiornamento. Funziona tutto eccetto il fatto che devo connettere l'hdd dopo che il pc si è acceso, altrimenti mpd non lo vede.

prova qua
https://www.youtube.com/watch?v=-Qwr3e7oPN0
oppure inserendo una stringa nel fstab
https://help.ubuntu.com/community/AutomaticallyMountPartitions
criminale
criminale
Appassionato
Appassionato

Data d'iscrizione : 15.10.12
Numero di messaggi : 262
Località : Boaren
Occupazione/Hobby : Spacabali
Provincia (Città) : Brescia (Perma in tal Cor)
Impianto : autocostruito alimentato a patate bollite

Torna in alto Andare in basso

problema music directory con MPD Empty Re: problema music directory con MPD

Messaggio Da vds il Mer 23 Apr 2014 - 0:05

@acvtre ha scritto:Alura, ho un nuovo aggiornamento. Funziona tutto eccetto il fatto che devo connettere l'hdd dopo che il pc si è acceso, altrimenti mpd non lo vede.

Quando ho configurato mpd sulla cubieboard per avere il mount all'avvio e non avendo voglia di "rompermi le scatole" con l'automount, ho semplicemente aggiunto all'inizio script di avvio di mpd nel directory /etc/init.d il comando  
Codice:
mount -a
in questo modo mentre sta lanciando il demone di mpd  monta anche tutto il montabile (a dire il vero anche quando si ferma il servizio o lo si riavvia ma a me questo non importava).
Mi rendo conto che non è un approccio ortodosso ma per me ha funzionato e mi sono risparmiato diverse rotture di scatole...
vds
vds
Affezionato
Affezionato

Data d'iscrizione : 01.11.10
Numero di messaggi : 172
Provincia (Città) : TV
Impianto : Chromecast - Denon x3000 - Yamaha p2500s - Cerwin Vega v12F


Torna in alto Andare in basso

problema music directory con MPD Empty Re: problema music directory con MPD

Messaggio Da acvtre il Mer 23 Apr 2014 - 14:19

@vds ha scritto:
@acvtre ha scritto:Alura, ho un nuovo aggiornamento. Funziona tutto eccetto il fatto che devo connettere l'hdd dopo che il pc si è acceso, altrimenti mpd non lo vede.

Quando ho configurato mpd sulla cubieboard per avere il mount all'avvio e non avendo voglia di "rompermi le scatole" con l'automount, ho semplicemente aggiunto all'inizio script di avvio di mpd nel directory /etc/init.d il comando  
Codice:
mount -a
in questo modo mentre sta lanciando il demone di mpd  monta anche tutto il montabile (a dire il vero anche quando si ferma il servizio o lo si riavvia ma a me questo non importava).
Mi rendo conto che non è un approccio ortodosso ma per me ha funzionato e mi sono risparmiato diverse rotture di scatole...
Ma precisamente dove lo hai scritto? Io sono andato in /etc/init.d/mpd e l'ho scritto nella primissima riga, ma non fa niente.

Ogni tanto mi fa lo stesso scherzo anche con la chiavetta wifi. Non si connette all'avvio e così devo staccarla e riattacarla.
acvtre
acvtre
Membro classe bronzo
Membro classe bronzo

Data d'iscrizione : 15.06.09
Numero di messaggi : 1834
Località : Romans d'Isonzo (GO)
Occupazione/Hobby : studente d'ingegneria dei materiali a Trieste
Provincia (Città) : Adelante
Impianto : Sorgente: voyage pc
Dac: ???
Amplificatore: per ora un vecchio sony TA-AX250
Diffusori: linn keilidh (con basi in granito)
Mobile: tnt-flexy autocostruito
Audio portatile: smartphone sony xperia sole, superlux hd381, x-minimax


http://www.myhifi.it/

Torna in alto Andare in basso

problema music directory con MPD Empty Re: problema music directory con MPD

Messaggio Da vds il Mer 23 Apr 2014 - 17:57

@acvtre ha scritto:
@vds ha scritto:

Quando ho configurato mpd sulla cubieboard per avere il mount all'avvio e non avendo voglia di "rompermi le scatole" con l'automount, ho semplicemente aggiunto all'inizio script di avvio di mpd nel directory /etc/init.d il comando  
Codice:
mount -a
in questo modo mentre sta lanciando il demone di mpd  monta anche tutto il montabile (a dire il vero anche quando si ferma il servizio o lo si riavvia ma a me questo non importava).
Mi rendo conto che non è un approccio ortodosso ma per me ha funzionato e mi sono risparmiato diverse rotture di scatole...
Ma precisamente dove lo hai scritto? Io sono andato in /etc/init.d/mpd e l'ho scritto nella primissima riga, ma non fa niente.

Ogni tanto mi fa lo stesso scherzo anche con la chiavetta wifi. Non si connette all'avvio e così devo staccarla e riattacarla.

Se la memoria non mi inganna lo avevo scritto appena sotto
#!/bin/sh
ma anche come hai fatto tu dovrebbe andare bene. Evidentemente la strada non è quella giusta...
Eventualmente per provare lo script basta lanciare (con i permessi di root)
/etc/init.d/mpd

il fatto che ogni tanto ti spariscano le periferiche usb è strano, se quando riscontri il problema digiti lsusb riesci a vederle nella lista?
vds
vds
Affezionato
Affezionato

Data d'iscrizione : 01.11.10
Numero di messaggi : 172
Provincia (Città) : TV
Impianto : Chromecast - Denon x3000 - Yamaha p2500s - Cerwin Vega v12F


Torna in alto Andare in basso

problema music directory con MPD Empty Re: problema music directory con MPD

Messaggio Da Contenuto sponsorizzato


Contenuto sponsorizzato


Torna in alto Andare in basso

Torna in alto


 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum