T-Forum, la vera HiFi alla portata di tutti
Benvenuto nel T-Forum!
Connettiti in modo da farti riconoscere come membro affezionato, oppure registrati così potrai partecipare attivamente alle discussioni.

voyage, bluetooth & android

Pagina 2 di 2 Precedente  1, 2

Andare in basso

Re: voyage, bluetooth & android

Messaggio Da alexdz il Lun 20 Mag 2013 - 18:08

Dalle schermate del log pero' non vedo i tentativi di connessione dello smartphone. Prova a stabilire un collegamento e vedi che messaggi compaiono.

alexdz
Interessato
Interessato

Data d'iscrizione : 23.08.12
Numero di messaggi : 88
Provincia (Città) : Vicenza
Impianto : Sorgenti: Sony CDP-790, Rpi2+MPD+IQAudio DAC+ - Amplificatore: Sony TA-F210 - Casse: Indiana Line 022 - Cuffie: Audio Technica Pro ATH-M40X, Sennheiser HD201


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da andreaea il Lun 20 Mag 2013 - 18:25

nel frattempo sto facendo altri tentativi e ho provato a rimuovere l'obbligo del log con la password come descritto in questa pagina dove dice: If you wish to proceed without using authentication so that you can test it easy, then put the following in /etc/hostapd/hostapd.conf

interface=wlan0
driver=nl80211
ssid=MyAP
hw_mode=g
channel=11


ora riesco ad entrare con lo smartphone (impostando un ip statico 10.1.10.5) ma la connessione sembra molto instabile e ogni pochi secondi lo smartphone riesegue la scansione delle reti e poi si riconnette alla mia wireless.
Il problema è che il client che vorrei usare per remotare mpd (che si chiama MPdroid) in pratica non funziona per via delle continue disconnessioni/riconnessioni e non riesco a remotare una bella cippa (non vedo nemmeno l'elenco degli artisti) e continua a chiedermi di connettermi al server. Crying or Very sad




andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da Switters il Lun 20 Mag 2013 - 23:28

A che distanza sei dal PC? Ci sono ostacoli in mezzo?
Per android c'è un'applicazione che si chiama "Analizzatore Wifi" che visualizza le reti trovate, la potenza del segnale, ecc. Inoltre per ogni canale dice quanto è "affollato", potresti provare a usare uno dei canali meno impegnati.
La chiavetta del PC è b/g/n? E lo smartphone?

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da andreaea il Mar 21 Mag 2013 - 8:59

Cell e pc sono a meno di un metro e non ci sono assolutamente ostacoli tra la chiavetta e il cell.: sono "a vista"

Sul cell. quando faccio lo scan delle reti wifi, mi dice che il segnale della mia rete è molto forte.

Come dovrei fare a "provare a usare uno dei canali meno impegnati"?

Scusa la mia ignoranza, ma cosa vuol dire se la chiavetta è b/g/n?
La mia chiavetta è questa qui http://www.digicom.it/digisit/prodotti.nsf/itprodottiidx/UsbWave150Nano e da qualche parte quando davo un segnale a terminale ho scoperto questa sigla rtl8192cu (non so se sia il firmware o cosa ma magari può essere utile).
Mi hanno consigliato questo sito per i drivers http://wireless.kernel.org/, sonob andato a dare un'occhiata ma sinceramente non ci ho capito nulla.
Può darsi che non siano stati caricati i drivers giusti?
Io ho fatto come mi è stato consigliato e per caricarli ho usato il comando
Codice:
apt-get install firmware-ralink

Il mio smartphone è un Samsung Galaxy S3 mini e per remotare uso un'app chiamata MPDroid che si interfaccia con MPD (la uso già con la lan e il router wifi e funziona egregiamente).


andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da alexdz il Mer 22 Mag 2013 - 9:35

L'rtl8192cu è il driver per alcune chiavette wi-fi con chipset Realtek; esso è contenuto nel pacchetto di debian (e quindi vale anche per voyage) firmware-realtek. Vedi qui:
http://wiki.debian.org/rtl819x
Se il sistema vede la chiavetta vuol dire che il pacchetto in questione è stato installato; se digiti lsmod in un terminale dovresti vedere il modulo con il driver caricato dal sistema.

Il problema di connessione non credo che sia dovuto al driver.
Come ti è già stato consigliato, prova a cambiare in hostapd.conf il numero di canale (channel= prova con un numero tra 1 e 11) e protocollo (hw_mode=, prova con b al posto di g).

alexdz
Interessato
Interessato

Data d'iscrizione : 23.08.12
Numero di messaggi : 88
Provincia (Città) : Vicenza
Impianto : Sorgenti: Sony CDP-790, Rpi2+MPD+IQAudio DAC+ - Amplificatore: Sony TA-F210 - Casse: Indiana Line 022 - Cuffie: Audio Technica Pro ATH-M40X, Sennheiser HD201


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da Switters il Mer 22 Mag 2013 - 10:02

@andreaea ha scritto:Scusa la mia ignoranza, ma cosa vuol dire se la chiavetta è b/g/n?

b/g/n sono versioni del protocollo WiFi 802.11 e si differenziano per la velocità massima di connessione.
La tua chiavetta supporta tutti e tre i protocolli, bisogna vedere se anche il telefono lo fa, è comunque possibile che ci sia qualche incompatibilità tra telefono e chiavetta, prova come ti è stato suggerito impostando il protocollo "b", se vedi che la connessione non è stabile prova anche "g" e "n".

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da andreaea il Mer 22 Mag 2013 - 13:50

rieccomi...

Allora, ho provato ad installare i drivers come descritto qui http://wiki.debian.org/rtl819x#Debian_7.0_.22Wheezy.22

Poi ho povato con tutte le impostazioni che mi avete suggerito per il file hostapd.conf.

Dunque, l'impostazione hw_mode=n non funziona
quando imposto il dato con n poi riavvio hostapd con
Codice:
/etc/init.d/hostapd restart
ottengo un messaggio di errore.
Ho provato le altre 2 impostazioni (b e g) e funzionano.
Allora ho provato a modificare come mi avete suggerito il numero di canale (channel=). Ho provato tutti inumeri da 1 a 11 sia con hw_mode=b che con hw_mode=g ma niente da fare.
Il cell. vede la rete wifi, si connette senza problemi, poi dopo pochi secondi riparte una scansione rete, e a volte si riconnette, altre volte non trova la rete per qualche secondo (me la segna come "fuori intervallo") poi riparte un'altra scansione e mi trova ancora la rete e ci si riconnette, per poi, dopo pochi secondi ripartire un'altra scansione e così all'infinito. Crazy
Sembra che la rete non sia stabile.
Se invece connetto il cell. alla rete del router la aggancia e non la molla più anche se esegue ogni pochi secondi la scansione rete e ne trova delle altre attive.





andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da alexdz il Mer 22 Mag 2013 - 14:13

@andreaea ha scritto:Sembra che la rete non sia stabile.
Se invece connetto il cell. alla rete del router la aggancia e non la molla più anche se esegue ogni pochi secondi la scansione rete e ne trova delle altre attive.

Ma non puoi disabilitare nel cell. la scansione continua delle reti?
Magari il problema sta li'.
Se possibile, prova anche a connetterti con qualche altro dispositivo wi-fi, per capire se il problema sta in hostapd o nel cell.

alexdz
Interessato
Interessato

Data d'iscrizione : 23.08.12
Numero di messaggi : 88
Provincia (Città) : Vicenza
Impianto : Sorgenti: Sony CDP-790, Rpi2+MPD+IQAudio DAC+ - Amplificatore: Sony TA-F210 - Casse: Indiana Line 022 - Cuffie: Audio Technica Pro ATH-M40X, Sennheiser HD201


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da Switters il Mer 22 Mag 2013 - 14:29

@andreaea ha scritto:Se invece connetto il cell. alla rete del router la aggancia e non la molla più anche se esegue ogni pochi secondi la scansione rete e ne trova delle altre attive.

Ma allora non puoi usare il router per il WiFi?
Configuri anche il PC per collegarsi al router, magari con un indirizzo IP statico e via...

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da andreaea il Mer 22 Mag 2013 - 14:46

@alexdz ha scritto:Ma non puoi disabilitare nel cell. la scansione continua delle reti?
Magari il problema sta li'.
Se possibile, prova anche a connetterti con qualche altro dispositivo wi-fi, per capire se il problema sta in hostapd o nel cell.
Al momento su internet (ho googlato un bel pò) non ho trovato nulla che si possa fare per impedire allo smartphone di eseguire la scansione automatica delle reti.

Purtroppo non ho la possibilità di fare prove con altri smatphones.
Comunque mi sembra veramentre strano perchè il web è pieno di articoli di persone che creano hot spots con linux e non ho letto dei problemi che sto riscontrando io.

@Switters ha scritto:
Ma allora non puoi usare il router per il WiFi?
Configuri anche il PC per collegarsi al router, magari con un indirizzo IP statico e via...
Purtroppo il pc linux lo userò senza avere avere la possibilità di accedere ad un router, quindi devo per forza usare una chiavetta wi fi (in pratica devo avere un pc "standalone" che dove lo metto funziona).
Per questo motivo sto ravanando così altrimenti il mio cell si connette già e remota egregiamente il pc connettendosi con il router wifi di casa.

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da alexdz il Mer 22 Mag 2013 - 23:34

@andreaea ha scritto:Comunque mi sembra veramentre strano perchè il web è pieno di articoli di persone che creano hot spots con linux e non ho letto dei problemi che sto riscontrando io.

Hostapd di solito funziona egregiamente: io a suo tempo ci feci un access-point al quale collegavo un po' di tutto.. pc, cellulare, wii, tv... ed il collegamento era stabile.
Continuo a sospettare che dipenda dal tuo smartphone.

alexdz
Interessato
Interessato

Data d'iscrizione : 23.08.12
Numero di messaggi : 88
Provincia (Città) : Vicenza
Impianto : Sorgenti: Sony CDP-790, Rpi2+MPD+IQAudio DAC+ - Amplificatore: Sony TA-F210 - Casse: Indiana Line 022 - Cuffie: Audio Technica Pro ATH-M40X, Sennheiser HD201


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da Switters il Gio 23 Mag 2013 - 0:37

Potrebbe essere una questione di compatibilità tra schede di rete wifi di smartphone e PC, a me è capitato con un Nokia e un access point, altri telefoni e PC riuscivano a collegarsi all'accesso point senza problemi, quel Nokia non c'è stato verso di farlo andare (ma riusciva a connettersi ad altri AP).

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da andreaea il Gio 30 Mag 2013 - 11:54

aggiornamenti
ho preso la chiavetta wifi usb consigliatami da mikelangeloz (questa qui) e ora la rete wifi funziona ed è stabile GRAZIE 1000! Smile

purtroppo ora ho un altro broblema Sad

ieri ho reinstallato Voyage Mpd (versione 0.9 rc2).
Ho creato una rete wifi e tutto funzionava alla grande: sono entrato con lo smartphone, e potevo lanciare i files musicali ecc.

Stamattina avvio il pc e ORRORE!! ricevo un messaggio di errore da Mpd: Starting Music Player Daemon: mpdFailed to bind to '192.168.1.69:6600': Cannot assign requested address no message buffer overruns
Mi potete per favore aiutare a capire cosa cavolo è successo?

Io entro in Voyage come root.
le impostazioni che ho sono:

/etc/mpd.conf
Codice:

user   "mpd"
#group "nogroup"
bind_to_address "192.168.1.69"
port   "6600"

/etc/default/mpd
Codice:

## Defaults for the MPD init script, sourced by /etc/init.d/mpd on Debian
## systems.  Uncomment (remove the leading '#') and change values as needed.

## Change this to prevent MPD from being started as a system service (for
## example, if you want to run it from a regular user account)
START_MPD=true

## The configuration file location for mpd:
# MPDCONF=/etc/mpd.conf

/etc/hostapd/hostapd.conf
Codice:

ctrl_interface=/var/run/hostapd
driver=nl80211
interface=wlan0
bridge=br0
hw_mode=g
channel=1
ssid=voyage-mpd
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=my_password
wpa_key_mgmt=WPA-PSK
wpa_pairwise=CCMP
rsn_pairwise=CCMP

/etc/network/interfaces
Codice:

auto lo
iface lo inet loopback

auto br0
iface br0 inet static
        address 192.168.1.50
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1
        bridge-ports eth0 wlan0

Il mio cell. android non ha problemi ad entrare nella rete wifi.
Il telefono ha ip 192.168.2.69 (glie lo do come statico)
Le impostazioni di mpdroid -> settings -> connection settings -> WLAN based connection -> voyage-mpd:
host: 192.168.1.69
port: 6600

La cosa veramente strana è che ieri sera funzionava tutto e ora no e non ho fatto nessuna modifica! Sad ho solo spento il pc ierisera e stamattina lo ho riavviato.
Ho cercato su internet ma non ho trovato gran che (a parte che di linux ci capisco veramente pochissimo).
Da quel poco che ho potuto intuire forse è un problema legato ad IPV6 (ma che cavolo sia non lo so), oppure dovrei loggare in Voyage come utente e non come root, oppure ancora è un problema di ermessi di scrittura su alcuni files?

questo articolo dice che è meglio creare una configurazione ad hoc per un utente anzichè una configurazione globale, magari è il mio caso?

qui ho trovato una discussione che forse può essere utile ma non ho capito molto
Grazie in anticipo a chi mi vorrà aiutare!


Ultima modifica di andreaea il Gio 30 Mag 2013 - 12:10, modificato 1 volta

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da alexdz il Gio 30 Mag 2013 - 12:04

@andreaea ha scritto:
bind_to_address "192.168.1.69"

prova a settare "any" per questo parametro.
Attenzione, forse era solo un errore di scrittura, ma hai scritto "Il telefono ha ip 192.168.2.69" quando la tua rete è 192.168.1.x.


alexdz
Interessato
Interessato

Data d'iscrizione : 23.08.12
Numero di messaggi : 88
Provincia (Città) : Vicenza
Impianto : Sorgenti: Sony CDP-790, Rpi2+MPD+IQAudio DAC+ - Amplificatore: Sony TA-F210 - Casse: Indiana Line 022 - Cuffie: Audio Technica Pro ATH-M40X, Sennheiser HD201


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da andreaea il Gio 30 Mag 2013 - 12:21

si era un errore di scrittura
ho provato con bind_to_address "any" non funzia Sad
ovvero, Mpd non da più errore, entro nella rete col cellulare ma non riesco a entrare in Mpd con MPDroid, quindi ci deve essere un problema.
Poi ripeto ieri sera funzionava tutto quindi le impostazioni che avevo dato ieri devono essere giuste per forza.
Secondo quanto ho capito è un problema di entrare come utente o come root.

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da alexdz il Gio 30 Mag 2013 - 12:29

Commenta in mpd.conf la riga:

user "mpd"

cosi' mpd girerà come root; male non fa, nonostante qualcuno pensi il contrario.


alexdz
Interessato
Interessato

Data d'iscrizione : 23.08.12
Numero di messaggi : 88
Provincia (Città) : Vicenza
Impianto : Sorgenti: Sony CDP-790, Rpi2+MPD+IQAudio DAC+ - Amplificatore: Sony TA-F210 - Casse: Indiana Line 022 - Cuffie: Audio Technica Pro ATH-M40X, Sennheiser HD201


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da Switters il Gio 30 Mag 2013 - 12:51

@alexdz ha scritto:cosi' mpd girerà come root; male non fa, nonostante qualcuno pensi il contrario.

No, male non fa, per quanto riguarda il normale funzionamento.
Il non farlo girare come root (in generale, vale per tutti i daemon, non solo per mpd) è solo una precauzione ai fini della sicurezza perché:
1) nel caso ci siano errori nel codice il demone non può fare danni in giro ma solo su file e directory di sua competenza (mentre se gira come root ha accesso a tutto il file system)
2) per gli stessi motivi, nel caso di presenza di "falle" nella sicurezza, se anche qualcuno trovasse il modo di sfruttarle avrebbe "solo" i permessi dell'utente e non quelli dello superuser (root).

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da andreaea il Gio 30 Mag 2013 - 13:13

Quindi come devo impostarlo?

io per installare Voyage seguo questa procedura, che se non erro installa Voyage come root e logga come root.
Come posso fare per installare non come root ma come utente X e loggare come utente X?

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da alexdz il Gio 30 Mag 2013 - 13:50

@andreaea ha scritto:
Come posso fare per installare non come root ma come utente X e loggare come utente X?

Come ti logghi e come si installa non c'entra nulla con quanto discusso sopra, che invece riguarda in quale veste il processo mpd gira una volta attivato.
Se in mpd.conf commenti la riga (commentare significa anteporre il simbolo #):
#user "mpd"

mpd quando va in esecuzione non girerà come processo dell'user "mpd" ma come processo di "root" con conseguente effetto anche a livello di permessi.

alexdz
Interessato
Interessato

Data d'iscrizione : 23.08.12
Numero di messaggi : 88
Provincia (Città) : Vicenza
Impianto : Sorgenti: Sony CDP-790, Rpi2+MPD+IQAudio DAC+ - Amplificatore: Sony TA-F210 - Casse: Indiana Line 022 - Cuffie: Audio Technica Pro ATH-M40X, Sennheiser HD201


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da Switters il Gio 30 Mag 2013 - 13:52

@andreaea ha scritto:Quindi come devo impostarlo?

Secondo me va bene anche come ti ha detto alexdz per verificare che funzioni, poi se riesci a farlo girare come "mpd" modificando lo user in mpd.conf tanto meglio.

io per installare Voyage seguo questa procedura, che se non erro installa Voyage come root e logga come root.
Come posso fare per installare non come root ma come utente X e loggare come utente X?

Si tratta di questioni diverse (installazione, login, esecuzione), il sistema operativo non puoi che installarlo come root. Il fatto che tu faccia login come root per configurare il sistema va benissimo, se ci devi fare altro (ma non credo sia questo il caso) è bene creare un utente per ciascun utilizzatore (anche se l'utilizzatore è solo uno). L'utente assegnato al processo in esecuzione invece è un altro discorso, ogni processo eredita lo uid (user id) dall'utente che lancia il processo, poi il processo stesso può fare delle chiamate di sistema perché gli venga attribuito un altro uid. Ad esempio, nel caso di mpd, appena parte il processo viene esguito come root ma subito dopo mpd chiede al sistema operativo (attraverso la chiamate di sistema setuid) di attribuirgliene uno diverso (cioé, nel caso specifico, quello impostato in mpd.conf).

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da andreaea il Gio 13 Giu 2013 - 11:49

Ciao, alla fine ho risolto, mi sono accorto che commettevo un errore assegnando un ip sbagliato al cellulare
grazie a tutti quelli che mi hanno aiutato. Smile

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: voyage, bluetooth & android

Messaggio Da Contenuto sponsorizzato


Contenuto sponsorizzato


Torna in alto Andare in basso

Pagina 2 di 2 Precedente  1, 2

Torna in alto

- Argomenti simili

 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum