T-Forum, la vera HiFi alla portata di tutti
Benvenuto nel T-Forum!
Connettiti in modo da farti riconoscere come membro affezionato, oppure registrati così potrai partecipare attivamente alle discussioni.
Ultimi argomenti
» Mission LX-2
Oggi alle 0:58 Da Kha-Jinn

» Giradischi project essential II
Ieri alle 23:56 Da giucam61

» Diffusore triste, voglio provare
Ieri alle 23:53 Da giucam61

» Vu meter audio
Ieri alle 23:16 Da clipper

» DAC per Raspberry
Ieri alle 22:50 Da gabri65

» Dubbi su Bluetooth
Ieri alle 21:07 Da GP9

» FX 802 vs Bantam Monoblock vs Nad 325BEE
Ieri alle 21:06 Da pinkflo2

» player di rete denon o marantz , ne vale la pena?
Ieri alle 21:06 Da gabri65

» Continuo con il Rasp o lascio perdere?
Ieri alle 20:51 Da gabri65

» Sorgente in sostituzione del Raspberry+Hifiberry
Ieri alle 20:36 Da gabri65

» Emu 1212m pci ex
Ieri alle 17:42 Da franz 01

» Am Audio A5 850 euro
Ieri alle 17:41 Da franz 01

» Sony uhp h1
Ieri alle 17:11 Da Luca Marchetti

» Consiglio gruppi power metal
Ieri alle 17:10 Da pij

» Invertire Sx con DX
Ieri alle 16:45 Da hsh1979

» PS Audio Nuwave o M2tech Young
Ieri alle 15:52 Da alessioashtangi

» Consiglio per upgrade diffusori / upgrade impianto
Ieri alle 13:01 Da giucam61

» Aleph 2 classe A 100W di Nelson Pass - chi ben comincia
Ieri alle 12:58 Da neno_07

» aiuto miglioramento sala d'ascolto
Ieri alle 12:10 Da gubos

» problema audio con Thorens TD320MKii
Ieri alle 10:59 Da elmolewis

» Cerco pre prebby hv
Ieri alle 9:59 Da verderame

» [Vendo] Nad C316BEE €210
Ieri alle 8:47 Da Dreammachine

» Acquisto dussun dove ?
Ieri alle 8:43 Da chiccoevani

» Nuovo Douk Dac
Lun 16 Ott 2017 - 23:55 Da uncletoma

» Consiglio impianto per diffusori KEF Coda 70
Lun 16 Ott 2017 - 21:44 Da Kha-Jinn

» consiglio su impianto digital
Lun 16 Ott 2017 - 21:13 Da Piper

» rumore fastidioso da dove viene?
Lun 16 Ott 2017 - 21:04 Da MaxBal

» Topic'it, nuova applicazione mobile per il T-Forum
Lun 16 Ott 2017 - 20:27 Da Luca Marchetti

» Foobar 2000 Darkone 4 come installarla!?
Lun 16 Ott 2017 - 19:19 Da H. Finn

» Fiio A5
Lun 16 Ott 2017 - 17:25 Da HeyGio'

Statistiche
Abbiamo 11084 membri registrati
L'ultimo utente registrato è HeyGio'

I nostri membri hanno inviato un totale di 797318 messaggi in 51695 argomenti
I postatori più attivi della settimana
giucam61
 
clipper
 
Masterix
 
GP9
 
Kha-Jinn
 
erduca
 
gabri65
 
ftalien77
 
Luca Marchetti
 
uncletoma
 

I postatori più attivi del mese
lello64
 
giucam61
 
nerone
 
dinamanu
 
ftalien77
 
Masterix
 
Kha-Jinn
 
Albert^ONE
 
kalium
 
erduca
 

Migliori postatori
Stentor (20392)
 
DACCLOR65 (19633)
 
schwantz34 (15532)
 
Silver Black (15480)
 
nd1967 (12803)
 
flovato (12509)
 
Biagio De Simone (10275)
 
piero7 (9854)
 
wasky (9229)
 
fritznet (9195)
 

Chi è in linea
In totale ci sono 37 utenti in linea: 0 Registrati, 0 Nascosti e 37 Ospiti :: 2 Motori di ricerca

Nessuno

[ Vedere la lista completa ]


Il numero massimo di utenti online contemporaneamente è stato 4379 il Lun 25 Mag 2015 - 15:01
Flusso RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 


Bookmarking sociale

Bookmarking sociale Digg  Bookmarking sociale Delicious  Bookmarking sociale Reddit  Bookmarking sociale Stumbleupon  Bookmarking sociale Slashdot  Bookmarking sociale Yahoo  Bookmarking sociale Google  Bookmarking sociale Blinklist  Bookmarking sociale Blogmarks  Bookmarking sociale Technorati  




Conserva e condividi l'indirizzo di T-Forum, la vera HiFi alla portata di tutti sul tuo sito sociale bookmarking


ALSA fa schifo?

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso

ALSA fa schifo?

Messaggio  Menestrello il Ven 4 Ott 2013 - 9:02

A leggere qui
http://www.linuxmusicians.com/viewtopic.php?f=6&t=10104&sid=c6ca47935760a4bddd3719cbf4375a1f

verrebbe da pensare che è pura fortuna se qualcosa funziona su Linux.
Don't know 
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Switters il Ven 4 Ott 2013 - 9:39

Non so se ALSA faccia schifo o meno ma mi sembra che il problema sia più che altro che i produttori di hardware utilizzano protocolli fuori standard, che implementano nei driver proprietari che rilasciano per Windows e OsX ma non per Linux (nel senso che per Linux non rilasciano proprio i driver).

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Menestrello il Ven 4 Ott 2013 - 9:47

Fuori standard?
Più che altro ogni produttore, giustamente, inserisce delle funzionalità aggiuntive nel proprio prodotto. Funzionalità per le quali estende lo standard non standard del protocollo.

Il protocollo USB audio 2 non esiste in realtà, o almeno definisce delle cose basilari.
Così mi pare di capire.
Don't know 
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Switters il Ven 4 Ott 2013 - 10:11

Sì, fuori standard nel senso che lo standard non prevede quelle funzionalità (tipo DSP, effetti, ecc).
Poi se il produttore decide di rilasciare solo i driver per Windows e OsX e non per Linux ci si dovrebbe lamentare con lui, lamentarsi con la comunità di sviluppatori di Linux non ha molto senso... Very Happy
Se un domani produco un pezzo di hardware e rilascio solo i driver per Linux voglio vedere chi va da Microsoft o da Apple a lamentarsi perché non ci sono i driver per i loro sistemi...

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Menestrello il Ven 4 Ott 2013 - 10:21

Per carità, è tutto giusto.
Però la considerazione fatta da j_e_f_f_g nel thread è pesante.
Software non documentato, fatto da hobbisti che non vogliono (possono?) spenderci più di qualche minuto.
Don't know 
Mi chiedo quale sia la qualità generale di ALSA.
Sad 
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Switters il Ven 4 Ott 2013 - 10:58

Non ho idea di come venga sviluppato ALSA, però è incluso nel kernel quindi immagino ci sia un minimo di controllo (certo non sulla documentazione, e il fatto che la documentazione riporti che sono supportate delle schede quando poi lo sono solo parzialmente, è poco simpatico).

Sarebbe utile che lo sviluppo venisse portato avanti da qualche distribuzione, come avviene per altri sottosistemi, solo che normalmente le aziende che producono una distribuzione hanno come clienti altre aziende a cui del sottosistema audio non gliene può fregare di meno.
L'unica grande distribuzione che si rivolge ai consumatori è Ubuntu ma dubito che riuscirebbero a sviluppare i driver per ogni scheda esistente senza il supporto dei produttori. Evidentemente i produttori non sono interessati alla fetta di mercato Linux... e questa è una cosa di cui tenere conto se se ne vuole fare un uso preofessionale.

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  alessandro1 il Ven 4 Ott 2013 - 12:33

non so per uso pro, però tra Ubuntu/alsa/deadbeef e XP/Asio/Foobar via USB c'è una differenza netta a favore del sistema linux. Tra Ubuntu/alsa/deadbeef e W7/WASAPI/Foobar, con Hiface one, non noto differenze di qualità, anche se tutto sommato hanno un sound differente. (ok potrebbero essere i miei gusti)
avatar
alessandro1
Membro classe argento
Membro classe argento

Data d'iscrizione : 31.01.12
Numero di messaggi : 3670
Provincia (Città) : PU
Impianto : Sorgente - Bristle Blocks 112
Ampli - Megablocks + Unico Plus -
Cavi - Duplo e play doh (DIY) su progetto Tony Wolf
diffusori - Stabilo 880 Woody
il resto è diy montessoriano


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  kocozze il Ven 4 Ott 2013 - 16:08

io pure utilizzo hiface one con alsa e non noto differenze rilevanti da xp con i driver forniti da m2tech...
avatar
kocozze
Appassionato
Appassionato

Data d'iscrizione : 21.11.09
Numero di messaggi : 257
Località : Roma
Impianto : Amplificatore e pre Nikko serie alpha e beta
casse Ess

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Switters il Ven 4 Ott 2013 - 16:16

Bisognerebbe provare con file ad alta risoluzione.
Comunque chi ha aperto la questione sul forum di linuxmusicians secondo me si riferiva più a schede audio e interfacce che vengono usate anche per la registrazione e la produzione di musica, non solo per la riproduzione.

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  alessandro1 il Ven 4 Ott 2013 - 17:10

kocozze ha scritto:io pure utilizzo hiface one con alsa e non noto differenze rilevanti da xp con i driver forniti da m2tech...
xp l'ho usato solo senza Hiface da USB ed era peggio di Ubuntu. Con i files con risoluzione 44.1 16 bit trovi che ubuntu e Xp siano sullo stesso livello?
avatar
alessandro1
Membro classe argento
Membro classe argento

Data d'iscrizione : 31.01.12
Numero di messaggi : 3670
Provincia (Città) : PU
Impianto : Sorgente - Bristle Blocks 112
Ampli - Megablocks + Unico Plus -
Cavi - Duplo e play doh (DIY) su progetto Tony Wolf
diffusori - Stabilo 880 Woody
il resto è diy montessoriano


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Dani81 il Ven 4 Ott 2013 - 17:27

Hiface Two e Windows 7 VS Ubuntu... 100 ad 1 per Linux con Alsa, non si discute.

Windows e audio sono parenti lontani Very Happy 
avatar
Dani81
Membro di riguardo
Membro di riguardo

Data d'iscrizione : 17.03.10
Numero di messaggi : 952
Località : Catania
Provincia (Città) : Come il Tempo
Impianto : Sorgente: Linux - HiFace2 + AirTech EVO 75Ohm - DAC: Audiolab M-Dac - Cavo Segnale: AirTech EVO Light 7N Cryo + SRC XLR Xhadow  - Cavo Alimentazione: AirTech EVO Light  7N Cryo + SRC - Ampli Cuffia/PRE Amplificatore: LD MK VI+ - Studio Monitor Attivi: Behringer TRUTH B1031A - Cuffie: HE-500 Hard Wire Balanced AirTech AIR -  Foto
...ho gusti semplici, scelgo solo il meglio (Oscar Wilde).

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  alessandro1 il Ven 4 Ott 2013 - 17:40

Dani81 ha scritto:Hiface Two e Windows 7 VS Ubuntu... 100 ad 1 per Linux con Alsa, non si discute.

Windows e audio sono parenti lontani Very Happy 
player ed eventualmente settaggi del player?

avatar
alessandro1
Membro classe argento
Membro classe argento

Data d'iscrizione : 31.01.12
Numero di messaggi : 3670
Provincia (Città) : PU
Impianto : Sorgente - Bristle Blocks 112
Ampli - Megablocks + Unico Plus -
Cavi - Duplo e play doh (DIY) su progetto Tony Wolf
diffusori - Stabilo 880 Woody
il resto è diy montessoriano


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Eulero il Ven 4 Ott 2013 - 18:46

Il problema non è alsa. Vi racconto una mia esperienza. Quando ho acquistato il DAC teac ud-h01, su molti siti veniva riportato come "class 2 usb audio" e quindi doveva funzionare con linux. Non era così e me ne accorsi sulla mia pelle. Per farvela breve contattai uno sviluppatore alsa di cui trovai la mail su internet. Mi portò per mano fino ad individuare i motivi per cui il dac non funzionava, trovò la patch e fu capace di farmi ricompilare tutto. (Era proprio un manico Hehe Hehe Hehe )
Il dac venne riconosciuto ed io capii che non solo i produttori di harware non scrivono drivers per Linux, ma non collaborano neanche con la comunità di sviluppatori, che specifiche alla mano sarebbero in grado risolvere molto più agevolmete problemi di compatibilità. La modifica venne inglobata nei kernel successivi.
Vi assicuro che contattai anche il produttore e mi disse che il loro dac non funzionava con linux ...
... pensate che abbiano ringraziato qualcuno?
In fondo se il loro dac funziona sotto linux i primi a guadagnarci sono loro stessi.
avatar
Eulero
Appassionato
Appassionato

Data d'iscrizione : 16.03.12
Numero di messaggi : 483
Località : Bologna
Impianto : Musica: su Nas Synology DS112
Sorgente: Voyage MPD su Via Epia N800
Trasporto: HiFace 2
Dac: Teac UD-H01
Amplificatore: Naim Nait 5i
Diffusori: ProAc Studio 130

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Dani81 il Ven 4 Ott 2013 - 19:04

alessandro1 ha scritto:
Dani81 ha scritto:Hiface Two e Windows 7 VS Ubuntu... 100 ad 1 per Linux con Alsa, non si discute.

Windows e audio sono parenti lontani Very Happy 
player ed eventualmente settaggi del player?

Messaggio #30

http://www.ilgazeboaudiofilo.com/t14548p15-l-impianto-liquido-cuffia-di-overdrive-full-airtech
avatar
Dani81
Membro di riguardo
Membro di riguardo

Data d'iscrizione : 17.03.10
Numero di messaggi : 952
Località : Catania
Provincia (Città) : Come il Tempo
Impianto : Sorgente: Linux - HiFace2 + AirTech EVO 75Ohm - DAC: Audiolab M-Dac - Cavo Segnale: AirTech EVO Light 7N Cryo + SRC XLR Xhadow  - Cavo Alimentazione: AirTech EVO Light  7N Cryo + SRC - Ampli Cuffia/PRE Amplificatore: LD MK VI+ - Studio Monitor Attivi: Behringer TRUTH B1031A - Cuffie: HE-500 Hard Wire Balanced AirTech AIR -  Foto
...ho gusti semplici, scelgo solo il meglio (Oscar Wilde).

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  kocozze il Sab 5 Ott 2013 - 0:04

alessandro1 ha scritto:
kocozze ha scritto:io pure utilizzo hiface one con alsa e non noto differenze rilevanti da xp con i driver forniti da m2tech...
xp l'ho usato solo senza Hiface da USB ed era peggio di Ubuntu. Con i files con risoluzione 44.1 16 bit trovi che ubuntu e Xp siano sullo stesso livello?
Dipende per me dall'ottimizzazione del s.o. piu' che dai driver. Ad esempio tra ubuntu o altra distro linux ed un xp ottimizzato con pochi processi c'e' un leggerissimo vantaggio per linux. Se poi ci buttiamo su distro ottimizzate per server audio compilate con mpd come voyage o mpdpup allora non c'e' storia, anche se non ho mai sentito l'equivalente su xp (verosimilmente cmp2)...questo ovviamente imho e col mio setup.

avatar
kocozze
Appassionato
Appassionato

Data d'iscrizione : 21.11.09
Numero di messaggi : 257
Località : Roma
Impianto : Amplificatore e pre Nikko serie alpha e beta
casse Ess

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Contenuto sponsorizzato


Contenuto sponsorizzato


Tornare in alto Andare in basso

Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto

- Argomenti simili

 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum