T-Forum, la vera HiFi alla portata di tutti
Benvenuto nel T-Forum!
Connettiti in modo da farti riconoscere come membro affezionato, oppure registrati così potrai partecipare attivamente alle discussioni.
Sondaggio

Ti piace il nuovo stile del T-Forum?

51% 51% [ 73 ]
49% 49% [ 70 ]

Totale dei voti : 143

Ultimi argomenti
» distanza crossover
Oggi alle 0:04 Da dinamanu

» Recensione personale Yamaha A-S701
Ieri alle 23:59 Da lello64

» è possibile che le valvole fischino?
Ieri alle 23:40 Da il luca

» Configurazione Impianto per usufruire musica liquida (TIDAL, NAS etc)
Ieri alle 23:31 Da Motogiullare

» Douk DAC (XMOS+PCM5102/DSD1796): ne vale la pena?
Ieri alle 22:57 Da joe1976

» Consiglio Ampli.
Ieri alle 22:41 Da Falco Maurizio

» R39 by Bellino
Ieri alle 21:51 Da mecoc

» Amplificatore con TDA2050
Ieri alle 20:13 Da corry24

» LP HiFi News Analogue Test Record +Thorens Td 295 mk4 + Ortofon 2M Blue
Ieri alle 19:24 Da giuseppe@scorzelli.it

» scanspeak sta' un pezzo avanti!
Ieri alle 16:43 Da dinamanu

» Technics SL 1200 Mk2
Ieri alle 15:42 Da Redcor

» info Cavi per cuffia autocostruito
Ieri alle 11:59 Da Diesellolle

» Vendo preamplificatore FX Audio TUBE-01 40€
Ieri alle 11:44 Da Charli48

» Consiglio Cuffie In Ear
Ieri alle 11:33 Da Diesellolle

» Tweak Whaferdale Diamond 9.6
Ieri alle 11:32 Da TOC1981

» ALIENTEK D8
Ieri alle 10:19 Da giucam61

» Emulatore Raspberry PI
Ieri alle 9:55 Da almo70

»  [BS+ss] Vendo dac Yulong ADA1 con inclusa scheda wi fi
Ieri alle 9:08 Da turo91

» wtfplay
Mar 23 Mag 2017 - 22:02 Da pallapippo

» Costruire casse per full range vintage.
Mar 23 Mag 2017 - 19:56 Da natale55

» Lettore ALL IN ONE definitivo
Mar 23 Mag 2017 - 19:19 Da RAIS

» Software APM Tool Lite
Mar 23 Mag 2017 - 18:46 Da gubos

» Nuova alimentazione per Virtue One
Mar 23 Mag 2017 - 18:19 Da silver surfer

» Conoscete questo valvolare 300b??
Mar 23 Mag 2017 - 14:30 Da Giovanni duck

» Vendo finale Icepower 125 asx2 €240 + s.s.
Mar 23 Mag 2017 - 8:50 Da chiccoevani

» case per tpa3116
Mar 23 Mag 2017 - 0:27 Da Giovanni duck

» Entrare nel mondo DIY, ma quale chip usare?
Lun 22 Mag 2017 - 22:52 Da mt196

» Chromecast audio... aiuto per usarlo al meglio, adesso solo polvere
Lun 22 Mag 2017 - 22:35 Da nerone

» INDIPENDENTEMENTE DALLA CLASSE DI FUNZIONAMENTO ...
Lun 22 Mag 2017 - 20:58 Da giucam61

» Valvolare kt88
Lun 22 Mag 2017 - 19:28 Da Giovanni duck

Statistiche
Abbiamo 10819 membri registrati
L'ultimo utente registrato è bresaola

I nostri membri hanno inviato un totale di 786878 messaggi in 51134 argomenti
I postatori più attivi della settimana
dinamanu
 
giucam61
 
mecoc
 
Giovanni duck
 
sportyerre
 
Falco Maurizio
 
nerone
 
silver surfer
 
Seti
 
mt196
 

Migliori postatori
Stentor (20392)
 
DACCLOR65 (19630)
 
schwantz34 (15503)
 
Silver Black (15459)
 
nd1967 (12803)
 
flovato (12509)
 
Biagio De Simone (10261)
 
piero7 (9854)
 
wasky (9229)
 
fritznet (8997)
 

Chi è in linea
In totale ci sono 38 utenti in linea: 2 Registrati, 0 Nascosti e 36 Ospiti :: 2 Motori di ricerca

Anto73, SubitoMauro

[ Vedere la lista completa ]


Il numero massimo di utenti online contemporaneamente è stato 4379 il Lun 25 Mag 2015 - 15:01
Flusso RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 


Bookmarking sociale

Bookmarking sociale Digg  Bookmarking sociale Delicious  Bookmarking sociale Reddit  Bookmarking sociale Stumbleupon  Bookmarking sociale Slashdot  Bookmarking sociale Yahoo  Bookmarking sociale Google  Bookmarking sociale Blinklist  Bookmarking sociale Blogmarks  Bookmarking sociale Technorati  




Conserva e condividi l'indirizzo di T-Forum, la vera HiFi alla portata di tutti sul tuo sito sociale bookmarking


ALSA fa schifo?

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso

ALSA fa schifo?

Messaggio  Menestrello il Ven 4 Ott 2013 - 9:02

A leggere qui
http://www.linuxmusicians.com/viewtopic.php?f=6&t=10104&sid=c6ca47935760a4bddd3719cbf4375a1f

verrebbe da pensare che è pura fortuna se qualcosa funziona su Linux.
Don't know 
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Switters il Ven 4 Ott 2013 - 9:39

Non so se ALSA faccia schifo o meno ma mi sembra che il problema sia più che altro che i produttori di hardware utilizzano protocolli fuori standard, che implementano nei driver proprietari che rilasciano per Windows e OsX ma non per Linux (nel senso che per Linux non rilasciano proprio i driver).

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Menestrello il Ven 4 Ott 2013 - 9:47

Fuori standard?
Più che altro ogni produttore, giustamente, inserisce delle funzionalità aggiuntive nel proprio prodotto. Funzionalità per le quali estende lo standard non standard del protocollo.

Il protocollo USB audio 2 non esiste in realtà, o almeno definisce delle cose basilari.
Così mi pare di capire.
Don't know 
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Switters il Ven 4 Ott 2013 - 10:11

Sì, fuori standard nel senso che lo standard non prevede quelle funzionalità (tipo DSP, effetti, ecc).
Poi se il produttore decide di rilasciare solo i driver per Windows e OsX e non per Linux ci si dovrebbe lamentare con lui, lamentarsi con la comunità di sviluppatori di Linux non ha molto senso... Very Happy
Se un domani produco un pezzo di hardware e rilascio solo i driver per Linux voglio vedere chi va da Microsoft o da Apple a lamentarsi perché non ci sono i driver per i loro sistemi...

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Menestrello il Ven 4 Ott 2013 - 10:21

Per carità, è tutto giusto.
Però la considerazione fatta da j_e_f_f_g nel thread è pesante.
Software non documentato, fatto da hobbisti che non vogliono (possono?) spenderci più di qualche minuto.
Don't know 
Mi chiedo quale sia la qualità generale di ALSA.
Sad 
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Switters il Ven 4 Ott 2013 - 10:58

Non ho idea di come venga sviluppato ALSA, però è incluso nel kernel quindi immagino ci sia un minimo di controllo (certo non sulla documentazione, e il fatto che la documentazione riporti che sono supportate delle schede quando poi lo sono solo parzialmente, è poco simpatico).

Sarebbe utile che lo sviluppo venisse portato avanti da qualche distribuzione, come avviene per altri sottosistemi, solo che normalmente le aziende che producono una distribuzione hanno come clienti altre aziende a cui del sottosistema audio non gliene può fregare di meno.
L'unica grande distribuzione che si rivolge ai consumatori è Ubuntu ma dubito che riuscirebbero a sviluppare i driver per ogni scheda esistente senza il supporto dei produttori. Evidentemente i produttori non sono interessati alla fetta di mercato Linux... e questa è una cosa di cui tenere conto se se ne vuole fare un uso preofessionale.

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  alessandro1 il Ven 4 Ott 2013 - 12:33

non so per uso pro, però tra Ubuntu/alsa/deadbeef e XP/Asio/Foobar via USB c'è una differenza netta a favore del sistema linux. Tra Ubuntu/alsa/deadbeef e W7/WASAPI/Foobar, con Hiface one, non noto differenze di qualità, anche se tutto sommato hanno un sound differente. (ok potrebbero essere i miei gusti)
avatar
alessandro1
Membro classe argento
Membro classe argento

Data d'iscrizione : 31.01.12
Numero di messaggi : 3617
Provincia (Città) : PU
Impianto : Sorgente - Bristle Blocks 112
Ampli - Megablocks + Unico Plus -
Cavi - Duplo e play doh (DIY) su progetto Tony Wolf
diffusori - Stabilo 880 Woody
il resto è diy montessoriano


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  kocozze il Ven 4 Ott 2013 - 16:08

io pure utilizzo hiface one con alsa e non noto differenze rilevanti da xp con i driver forniti da m2tech...
avatar
kocozze
Appassionato
Appassionato

Data d'iscrizione : 21.11.09
Numero di messaggi : 257
Località : Roma
Impianto : Amplificatore e pre Nikko serie alpha e beta
casse Ess

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Switters il Ven 4 Ott 2013 - 16:16

Bisognerebbe provare con file ad alta risoluzione.
Comunque chi ha aperto la questione sul forum di linuxmusicians secondo me si riferiva più a schede audio e interfacce che vengono usate anche per la registrazione e la produzione di musica, non solo per la riproduzione.

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  alessandro1 il Ven 4 Ott 2013 - 17:10

@kocozze ha scritto:io pure utilizzo hiface one con alsa e non noto differenze rilevanti da xp con i driver forniti da m2tech...
xp l'ho usato solo senza Hiface da USB ed era peggio di Ubuntu. Con i files con risoluzione 44.1 16 bit trovi che ubuntu e Xp siano sullo stesso livello?
avatar
alessandro1
Membro classe argento
Membro classe argento

Data d'iscrizione : 31.01.12
Numero di messaggi : 3617
Provincia (Città) : PU
Impianto : Sorgente - Bristle Blocks 112
Ampli - Megablocks + Unico Plus -
Cavi - Duplo e play doh (DIY) su progetto Tony Wolf
diffusori - Stabilo 880 Woody
il resto è diy montessoriano


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Dani81 il Ven 4 Ott 2013 - 17:27

Hiface Two e Windows 7 VS Ubuntu... 100 ad 1 per Linux con Alsa, non si discute.

Windows e audio sono parenti lontani Very Happy 
avatar
Dani81
Membro di riguardo
Membro di riguardo

Data d'iscrizione : 17.03.10
Numero di messaggi : 952
Località : Catania
Provincia (Città) : Come il Tempo
Impianto : Sorgente: Linux - HiFace2 + AirTech EVO 75Ohm - DAC: Audiolab M-Dac - Cavo Segnale: AirTech EVO Light 7N Cryo + SRC XLR Xhadow  - Cavo Alimentazione: AirTech EVO Light  7N Cryo + SRC - Ampli Cuffia/PRE Amplificatore: LD MK VI+ - Studio Monitor Attivi: Behringer TRUTH B1031A - Cuffie: HE-500 Hard Wire Balanced AirTech AIR -  Foto
...ho gusti semplici, scelgo solo il meglio (Oscar Wilde).

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  alessandro1 il Ven 4 Ott 2013 - 17:40

@Dani81 ha scritto:Hiface Two e Windows 7 VS Ubuntu... 100 ad 1 per Linux con Alsa, non si discute.

Windows e audio sono parenti lontani Very Happy 
player ed eventualmente settaggi del player?

avatar
alessandro1
Membro classe argento
Membro classe argento

Data d'iscrizione : 31.01.12
Numero di messaggi : 3617
Provincia (Città) : PU
Impianto : Sorgente - Bristle Blocks 112
Ampli - Megablocks + Unico Plus -
Cavi - Duplo e play doh (DIY) su progetto Tony Wolf
diffusori - Stabilo 880 Woody
il resto è diy montessoriano


Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Eulero il Ven 4 Ott 2013 - 18:46

Il problema non è alsa. Vi racconto una mia esperienza. Quando ho acquistato il DAC teac ud-h01, su molti siti veniva riportato come "class 2 usb audio" e quindi doveva funzionare con linux. Non era così e me ne accorsi sulla mia pelle. Per farvela breve contattai uno sviluppatore alsa di cui trovai la mail su internet. Mi portò per mano fino ad individuare i motivi per cui il dac non funzionava, trovò la patch e fu capace di farmi ricompilare tutto. (Era proprio un manico Hehe Hehe Hehe )
Il dac venne riconosciuto ed io capii che non solo i produttori di harware non scrivono drivers per Linux, ma non collaborano neanche con la comunità di sviluppatori, che specifiche alla mano sarebbero in grado risolvere molto più agevolmete problemi di compatibilità. La modifica venne inglobata nei kernel successivi.
Vi assicuro che contattai anche il produttore e mi disse che il loro dac non funzionava con linux ...
... pensate che abbiano ringraziato qualcuno?
In fondo se il loro dac funziona sotto linux i primi a guadagnarci sono loro stessi.
avatar
Eulero
Appassionato
Appassionato

Data d'iscrizione : 16.03.12
Numero di messaggi : 483
Località : Bologna
Impianto : Musica: su Nas Synology DS112
Sorgente: Voyage MPD su Via Epia N800
Trasporto: HiFace 2
Dac: Teac UD-H01
Amplificatore: Naim Nait 5i
Diffusori: ProAc Studio 130

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Dani81 il Ven 4 Ott 2013 - 19:04

@alessandro1 ha scritto:
@Dani81 ha scritto:Hiface Two e Windows 7 VS Ubuntu... 100 ad 1 per Linux con Alsa, non si discute.

Windows e audio sono parenti lontani Very Happy 
player ed eventualmente settaggi del player?

Messaggio #30

http://www.ilgazeboaudiofilo.com/t14548p15-l-impianto-liquido-cuffia-di-overdrive-full-airtech
avatar
Dani81
Membro di riguardo
Membro di riguardo

Data d'iscrizione : 17.03.10
Numero di messaggi : 952
Località : Catania
Provincia (Città) : Come il Tempo
Impianto : Sorgente: Linux - HiFace2 + AirTech EVO 75Ohm - DAC: Audiolab M-Dac - Cavo Segnale: AirTech EVO Light 7N Cryo + SRC XLR Xhadow  - Cavo Alimentazione: AirTech EVO Light  7N Cryo + SRC - Ampli Cuffia/PRE Amplificatore: LD MK VI+ - Studio Monitor Attivi: Behringer TRUTH B1031A - Cuffie: HE-500 Hard Wire Balanced AirTech AIR -  Foto
...ho gusti semplici, scelgo solo il meglio (Oscar Wilde).

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  kocozze il Sab 5 Ott 2013 - 0:04

@alessandro1 ha scritto:
@kocozze ha scritto:io pure utilizzo hiface one con alsa e non noto differenze rilevanti da xp con i driver forniti da m2tech...
xp l'ho usato solo senza Hiface da USB ed era peggio di Ubuntu. Con i files con risoluzione 44.1 16 bit trovi che ubuntu e Xp siano sullo stesso livello?
Dipende per me dall'ottimizzazione del s.o. piu' che dai driver. Ad esempio tra ubuntu o altra distro linux ed un xp ottimizzato con pochi processi c'e' un leggerissimo vantaggio per linux. Se poi ci buttiamo su distro ottimizzate per server audio compilate con mpd come voyage o mpdpup allora non c'e' storia, anche se non ho mai sentito l'equivalente su xp (verosimilmente cmp2)...questo ovviamente imho e col mio setup.

avatar
kocozze
Appassionato
Appassionato

Data d'iscrizione : 21.11.09
Numero di messaggi : 257
Località : Roma
Impianto : Amplificatore e pre Nikko serie alpha e beta
casse Ess

Tornare in alto Andare in basso

Re: ALSA fa schifo?

Messaggio  Contenuto sponsorizzato


Contenuto sponsorizzato


Tornare in alto Andare in basso

Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto

- Argomenti simili

 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum