T-Forum, not just T-class. Since 2008, the affordable HiFi for you.
Benvenuto nel T-Forum!
Connettiti in modo da farti riconoscere come membro affezionato, oppure registrati così potrai partecipare attivamente alle discussioni.
Cerca
 
 

Risultati secondo:
 

 


Rechercher Ricerca avanzata

Ultimi argomenti
» Consigli per un novizio!
Oggi a 21:21 Da p.cristallini

» Oje Cavetto Anema 'e Core, nun mme scetà (valter)
Oggi a 21:21 Da Calbas

» Pulsante antivandalo da pannello
Oggi a 21:13 Da scontin

» Collegamento bi-wiring Marantz PM5005
Oggi a 19:43 Da Snap

» Stamattina... Oggi pomeriggio... Stasera... Stanotte... (parte 14)
Oggi a 19:16 Da CHAOSFERE

» [GE] Vendo Nuforce STA 100
Oggi a 19:12 Da scontin

» Le mie Vitriol personalizzate ed autocostruite
Oggi a 19:09 Da GP9

» ALIENTEK D8
Oggi a 18:24 Da CHAOSFERE

» fissa lettore CD
Oggi a 18:05 Da p.cristallini

» AudioNirvana Super 12" Cast Frame in cabinet 5.6MKII - risultato finale
Oggi a 18:02 Da giucam61

» MOD per Scyte Kro Craft rev B - come moddare un bestbuy con pochi euro !
Oggi a 17:26 Da Snap

» Breeze Audio TPA3116 a 20 euro spedizione compresa
Oggi a 17:22 Da alexdelli

» Sos cd
Oggi a 17:22 Da gigetto

» Problema Ampli.
Oggi a 17:20 Da Smanetton

» Consiglio per sistema audio per portatile
Oggi a 16:41 Da audiogian

» Testina Sanyo tp 625 help
Oggi a 15:38 Da beppe61

» Consiglio cuffie "da notte" economiche
Oggi a 14:51 Da Terenzio Catrame

» l'impedenza delle cambridge sx60 - simil-gainclone
Oggi a 14:34 Da Sregio

» mini hi fi con diffusori a eccitazione tattile piu' sub woofer
Oggi a 13:49 Da fritznet

» Consiglio diffusori DIY tra progetti di Alberto Bellino
Oggi a 13:21 Da CHAOSFERE

» Alientek d8 collegato a diffusori celestion 66 studio monitor
Oggi a 7:31 Da Drmirva

» Più potenza di un alientek d8
Oggi a 7:15 Da Drmirva

» Nuovi cavi potenza
Oggi a 7:09 Da Smanetton

» Io li pulisco cosi!
Ieri a 23:03 Da Aunktintaun

» Ampli+DAC+bluetooth tutto-in-uno: Sabaj Audio A2?
Ieri a 17:05 Da Gert87

» partiamo da zero ma proprio zero?
Ieri a 15:23 Da Snap

» Cuffie Sennheiser con filo o WiFi?
Ieri a 14:37 Da chopper77

» (RM + Sped.) Vendo integrato Hegel H100
Ieri a 12:22 Da Rick1982

» impianto entry -level
Ieri a 8:56 Da giucam61

» [GE] Vendo coppia finali mono Hypex nCore 400
Ieri a 0:59 Da antbom

» Diffusori ~7-900 Euro
Gio 23 Feb 2017 - 22:22 Da dinamanu

» Consiglio diffusori economici da scrivania: Dayton B652, B652 AIR o Scythe Kro Craft
Gio 23 Feb 2017 - 21:39 Da pietrob91

» Little dot mk 1+ modifica condensatori
Gio 23 Feb 2017 - 21:28 Da daltanius29877

» Lettore ALL IN ONE definitivo
Gio 23 Feb 2017 - 18:52 Da tix88

» Configurazione pc per musica liquida
Gio 23 Feb 2017 - 17:38 Da tambara1

» consiglio amplificatore
Gio 23 Feb 2017 - 16:32 Da mitroglu

» Vendo Cayin 220 CU
Gio 23 Feb 2017 - 14:59 Da wolfman

» Breeze Audio TPA3116 versione 2016?
Gio 23 Feb 2017 - 14:52 Da alexdelli

» Technics SL-QD22
Gio 23 Feb 2017 - 14:11 Da Snap

» chi si intende di grundig?
Gio 23 Feb 2017 - 13:29 Da sportyerre

» Ho comprato due nuovi gingilli, cosa ci costruisco attorno?
Gio 23 Feb 2017 - 12:03 Da giucam61

» Come montare punte e sottopunte
Gio 23 Feb 2017 - 9:27 Da Smanetton

» sento il suono dal giradischi
Mer 22 Feb 2017 - 23:31 Da fritznet

» Notebook o Macbook per Lavorare con la Musica
Mer 22 Feb 2017 - 22:25 Da BizarreBazaar

» Sw per nuovo PC
Mer 22 Feb 2017 - 17:09 Da tambara1

» Consiglio su lucidatura alluminio Marantz
Mer 22 Feb 2017 - 16:11 Da Luchezard

» Cambio diffussori da scaffale max 500euro
Mer 22 Feb 2017 - 14:20 Da natale55

» Problema MARATNZ PM 6006,si spegne
Mer 22 Feb 2017 - 13:25 Da Mario Maione

» Consiglio diffusori per Cambridge Audio AM10 con CD10
Mer 22 Feb 2017 - 13:06 Da Luca1982

» raspbian e dac i2s
Mer 22 Feb 2017 - 11:31 Da luigigi

Sondaggio

Interessati alla guida per la costruzione di un server audio?

77% 77% [ 156 ]
23% 23% [ 47 ]

Totale dei voti : 203

I postatori più attivi della settimana
CHAOSFERE
 
Snap
 
lello64
 
giucam61
 
Kha-Jinn
 
alexdelli
 
GP9
 
dinamanu
 
Aunktintaun
 
kalium
 

I postatori più attivi del mese
CHAOSFERE
 
Snap
 
giucam61
 
lello64
 
fritznet
 
Kha-Jinn
 
TODD 80
 
dinamanu
 
Aunktintaun
 
natale55
 

Migliori postatori
Stentor (20392)
 
DACCLOR65 (19629)
 
schwantz34 (15499)
 
Silver Black (15403)
 
nd1967 (12803)
 
flovato (12509)
 
Biagio De Simone (10260)
 
piero7 (9854)
 
wasky (9229)
 
fritznet (8786)
 

Statistiche
Abbiamo 10632 membri registrati
L'ultimo utente registrato è gmzande

I nostri membri hanno inviato un totale di 779307 messaggi in 50679 argomenti
Chi è in linea
In totale ci sono 68 utenti in linea :: 8 Registrati, 1 Nascosto e 59 Ospiti :: 2 Motori di ricerca

dtraina, enrico massa, GGiovanni, goldrake74, GP9, kalium, rincoman, TODD 80

[ Vedere la lista completa ]


Il numero massimo degli utenti in linea è stato 4379 il Lun 25 Mag 2015 - 15:01
Flusso RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 


Bookmarking sociale

Bookmarking sociale Digg  Bookmarking sociale Delicious  Bookmarking sociale Reddit  Bookmarking sociale Stumbleupon  Bookmarking sociale Slashdot  Bookmarking sociale Yahoo  Bookmarking sociale Google  Bookmarking sociale Blinklist  Bookmarking sociale Blogmarks  Bookmarking sociale Technorati  




Conserva e condividi l'indirizzo di T-Forum, not just T-class. Since 2008, the affordable HiFi for you. sul tuo sito sociale bookmarking

Linux e M51?

Pagina 2 di 3 Precedente  1, 2, 3  Seguente

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso

Re: Linux e M51?

Messaggio  donluca il Mer 28 Ago 2013 - 12:32

@Menestrello ha scritto:Diff e patch dovrebbero essere l'uno il complemento dell'altro e le modifiche riportate su SourceForge sono il risultato di una diff, quindi....

Il fatto è che io il codice sorgente lo voglio vedere e modificare a manina Wink Hehe 
Capisco perfettamente Hehe

donluca
Membro classe argento
Membro classe argento

Data d'iscrizione : 07.11.11
Numero di messaggi : 3647
Località : Roma
Occupazione/Hobby : Visionario informatico
Provincia (Città) : Roma
Impianto :
Spoiler:
Impianto principale:
Lettore SACD/DVDA: Yamaha S2700
Giradischi: Pro-ject Debut Carbon
Testina: Ortofon Super OM40
Pre Phono: NVA Phono 1
Pre-Amplificatore: Eden Passive Preamplifier
Finale: Advance Acoustics MAA406
Diffusori: Castle Conway 3 (moddati con dadi ciechi)

Impianto in camera:
Sorgente: iMac 27"
DAC: T.C. electronic Desktop Konnekt 6 (da moddare)
Giradischi: Rotel RP-900
Testina: Ortofon 2M Red
Pre Phono: Cambridge P540
Amplificatori: troppi (attualmente Sansui AU-217 II, rigenerato, da moddare)
Diffusori: Quad L-ite (da cambiare)
Amplificatore cuffie: Perreaux SXH2
Cuffie: HiFiMan HE-400, AKG K601, Creative Aurvana Live!, Xears XE200Pro, AKG Q460


http://16bitaudiophileproject.org

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  robertopisa il Mer 28 Ago 2013 - 14:25

Se usi emacs, c'è ediff che ti mostra riga per riga le diff e ti chiede se fare il merge oppure no. Complimenti per il DAC, poi ci dici come sei pervenuto alla scelta finale!

-R


@Menestrello ha scritto:Il fatto è che io il codice sorgente lo voglio vedere e modificare a manina Wink Hehe 

robertopisa
Membro classe bronzo
Membro classe bronzo

Data d'iscrizione : 08.04.10
Numero di messaggi : 1654
Provincia (Città) : Pisa
Impianto :
premi per vedere:


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Mer 28 Ago 2013 - 14:34

Ciao Roberto!
Una volta lo ascoltiamo insieme Smile 

Spero di riuscire a farlo funzionare con MPD sotto Linux, ma per ora niente da fare.

In una cartella avevo scaricato tempo addietro tutto il sorgente del kernel e ho fatto qualche modifica ai driver alsa.
(roba da stupidotti, ho commentato la funzione snd_usb_create_mixer() che da errore. Leggo che si può mettere il dispositivo nella quirk list ma non ho capito come fare a trovare i parametri da aggiungere, quindi per ora faccio questo esperimento)

Non mi riesce di compilare solo alsa, mi sa che dovrò ricompilare tutto. Sad 
Come faccio poi per installarlo?
Don't know 

La mia ignoranza in Linux è formidabile e si rinnova nel tempo, nel senso che tutto quello che imparo dopo un paio di mesi subito lo dimentico Laughing 

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Switters il Mer 28 Ago 2013 - 14:40

@Menestrello ha scritto:Non mi riesce di compilare solo alsa, mi sa che dovrò ricompilare tutto. Sad 
Come faccio poi per installarlo?
Intendi i driver ALSA nel kernel? Ricompila il kernel ("make && make modules && make modules_install", se non è cambiato qualcosa dall'ultima volta che ho compilato un kernel... Wink )

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Mer 28 Ago 2013 - 14:51

ma non posso ricompilare solo alsa e installare solo alsa???? Surprised Shocked Surprised 

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Switters il Mer 28 Ago 2013 - 15:30

Se su quella macchina hai già installato e compilato il kernel il make ricompila solo i sorgenti modificati, non dovrebbe durare molto, a meno che tu non abbia "ripulito" la directory del kernel con un "make mrproper" (o "make clean"?).
Magari è possibile anche compilare e installare solo il modulo, bisogna leggere la documentazione o fare una ricerca in rete...

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  robertopisa il Mer 28 Ago 2013 - 18:08

A chi lo dici... ho compilato pochi mesi fa per provare il driver hiface1 e non mi ricordo più una mazza. Il suggerimento di switters mi sembra un buon punto di partenza.

Hai provato anche questo? http://www.alsa-project.org/main/index.php/Driver_Compilation

E se sei ardimentoso... http://permalink.gmane.org/gmane.linux.alsa.devel/105601

Altrimenti spulcia i forum di ubuntu

Comunque pare che il NAD 51 abbia adoperato una versione estesa di UAC 2.0. Perché non scrivi direttamente al supporto NAD? Se dichiarano che è Linux compatibile, qualcosa dovranno pur dirti...

-R

@Menestrello ha scritto:In una cartella avevo scaricato tempo addietro tutto il sorgente del kernel e ho fatto qualche modifica ai driver alsa.
(roba da stupidotti, ho commentato la funzione snd_usb_create_mixer() che da errore. Leggo che si può mettere il dispositivo nella quirk list ma non ho capito come fare a trovare i parametri da aggiungere, quindi per ora faccio questo esperimento)

Non mi riesce di compilare solo alsa, mi sa che dovrò ricompilare tutto. Sad 
Come faccio poi per installarlo?
Don't know 

La mia ignoranza in Linux è formidabile e si rinnova nel tempo, nel senso che tutto quello che imparo dopo un paio di mesi subito lo dimentico Laughing 

robertopisa
Membro classe bronzo
Membro classe bronzo

Data d'iscrizione : 08.04.10
Numero di messaggi : 1654
Provincia (Città) : Pisa
Impianto :
premi per vedere:


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Mer 28 Ago 2013 - 18:23

mmmm....
per quello che ho letto, sembra più un problema di alsa con il descrittore esteso.
ma non mi chiedere cosa questo voglia dire:lol: 
al momento ho commentato la funzione in mixer.c che ritorna l'errore, o almeno spero.
vediamo cosa succede Shocked 

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Gio 29 Ago 2013 - 8:42

Dopo varie ricompilazioni e tentativi,
la situazione è leggermente cambiata: in /dev/snd il dispositivo si vede correttamente, il DAC riconosce la frequenza di campionamento e indica invece dello standard 192Kh i 44.1Khz

Però non succede nulla e dopo qualche secondo MPD da errore.
Sad 

Mi arrendo. Attendo una nuova versioni di Alsa o qualcosa da parte di NAD, anche se lo ritengo improbabile.

Mi sa che mi tocca passare a JPlay Don't know Mmm 


Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Switters il Gio 29 Ago 2013 - 9:10

Hai già provato a scaricare e compilare l'ultimo kernel da kernel.org?

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Gio 29 Ago 2013 - 9:43

@Switters ha scritto:Hai già provato a scaricare e compilare l'ultimo kernel da kernel.org?
Sarebbe da provare con un portatile.
Ma io uso questo



oppure questo



Don't know 

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Switters il Gio 29 Ago 2013 - 9:50

Se la distribuzione che usi ha tutto ciò che serve puoi compilare anche su quelle schede, ci metterà un po' di tempo ma può pure essere che te la cavi in una notte... Hehe Hehe Hehe 

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Gio 29 Ago 2013 - 10:00

Non ho il tempo per tutto ciò Sad 

Oltretutto senza alcuna garanzia che funzioni.

Per il momento ho aperto un ticket alla nad.
Non risolverà nulla, ma giusto per rompergli un po' le palle così come me le sono rotte io Hehe 

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  robertopisa il Gio 29 Ago 2013 - 15:23

Ganzo, avresti così un media player dedicato...
-R


@Menestrello ha scritto:
@Switters ha scritto:Hai già provato a scaricare e compilare l'ultimo kernel da kernel.org?
Sarebbe da provare con un portatile.
Ma io uso questo



oppure questo



Don't know 

robertopisa
Membro classe bronzo
Membro classe bronzo

Data d'iscrizione : 08.04.10
Numero di messaggi : 1654
Provincia (Città) : Pisa
Impianto :
premi per vedere:


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Ven 6 Set 2013 - 0:08

Io son testardo e ho ricompilato tutto il kernel con le versioni di alsa aggiornate e....
miracolo!
Il NAD M51 si vede in alsamixer!
Very Happy 

Ma MPD non funziona
Laughing Laughing Laughing Evil or Very Mad Evil or Very Mad Evil or Very Mad 

Nel log di MPD trovo
Codice:
output: "Nad1" [alsa] failed to filter: Conversion from 2 to 10 channels is not implemented
Con dmesg non vedo errori USB

Codice:
[  355.255000] usb 1-3.1: new high-speed USB device number 4 using s5p-ehci
[  355.360000] usb 1-3.1: New USB device found, idVendor=17ae, idProduct=0005
[  355.360000] usb 1-3.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  355.365000] usb 1-3.1: Product: NAD USB Audio 2.0
[  355.370000] usb 1-3.1: Manufacturer: NAD
[  355.375000] usb 1-3.1: SerialNumber: 0000
Googlando alla ricerca di possibili cause dell'errore non trovo nulla.
Suggerimenti?
Idee?
Don't know 

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  grunter il Ven 6 Set 2013 - 7:21

Sembra che lo veda come dac a 10canali e lì stia il problema, non ti fa scegliere tra più interfacce?

grunter
Membro classe argento
Membro classe argento

Data d'iscrizione : 16.12.10
Numero di messaggi : 3934
Località : Pistoia
Occupazione/Hobby : Informatica e Fotografia
Provincia (Città) : PT
Impianto :
Spoiler:

SORGENTE: Player Naudio con mod Robertopisa per upmixing da 2 a 8 canali su pc Windows Server 2012 R2
DAC: Merging Hapi
PRE: Audio Research LS 27
AMPLI: Krell fpb 400cx
CASSE: Vienna Acoustics Beethoven Concert Grand
CAVI ALIMENTAZIONE Neutral Cable Fascino
CAVI POTENZA Viablue sc4
CAVI SEGNALE Gotham GAC-2 Ultra Pro Hi-End
CAVO USB Neutral Cable Passion
CUFFIE: Sennheiser HD-800 - Beyerdynamic T90 - Shure 1840
AMPLI CUFFIE: Violectric V200
DAC/AMPLI CUFFIE: Geek Pulse Infinity - GeekOut1000


http://fsphoto.net63.net

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Ven 6 Set 2013 - 8:12

@grunter ha scritto:Sembra che lo veda come dac a 10canali e lì stia il problema, non ti fa scegliere tra più interfacce?
Infatti.
Ci deve essere un problema nel riconoscere il dispositivo USB, probabilmente qualche descrittore esteso che usa il NAD viene interpretato male.

Ma su San Google non riesco a trovare nulla Holy 

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Switters il Ven 6 Set 2013 - 9:01

Stesso problema con un M-Audio: http://bugs.musicpd.org/view.php?id=3644

Ma non ho capito se il problema è di MPD o di ALSA...

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Ven 6 Set 2013 - 9:08

@Switters ha scritto:Stesso problema con un M-Audio: http://bugs.musicpd.org/view.php?id=3644

Ma non ho capito se il problema è di MPD o di ALSA...
E' un problema di ALSA.
MPD prova ad inviare il flusso verso il dispositivo selezionato che risulta avere più canali.

In effetti è l'unica cosa che ho trovato anche io con Google.
Mmm 

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Switters il Ven 6 Set 2013 - 9:36

@Menestrello ha scritto:E' un problema di ALSA. 
Mmm... non ne sarei così sicuro, guarda un po' cosa si legge nei sorgenti di MPD in PcmConvert.cxx:

Codice:
if (src_format->channels != dest_format->channels) {
 buf = pcm_convert_channels_16(&channels_buffer,
      dest_format->channels,
      src_format->channels,
      buf, len, &len);
 if (buf == NULL) {
 g_set_error(error_r, pcm_convert_quark(), 0,
    "Conversion from %u to %u channels "
    "is not implemented",
    src_format->channels,
    dest_format->channels);
 return NULL;
 }
 }
Il messaggio non è generato da ALSA ma da MPD.
Hai la possibilità di provare un altro player?

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Ven 6 Set 2013 - 9:42

@Switters ha scritto:
@Menestrello ha scritto:E' un problema di ALSA. 
Mmm... non ne sarei così sicuro, guarda un po' cosa si legge nei sorgenti di MPD in PcmConvert.cxx:

Codice:
if (src_format->channels != dest_format->channels) {
 buf = pcm_convert_channels_16(&channels_buffer,
      dest_format->channels,
      src_format->channels,
      buf, len, &len);
 if (buf == NULL) {
 g_set_error(error_r, pcm_convert_quark(), 0,
    "Conversion from %u to %u channels "
    "is not implemented",
    src_format->channels,
    dest_format->channels);
 return NULL;
 }
 }
Il messaggio non è generato da ALSA ma da MPD.
Hai la possibilità di provare un altro player?
Certo, il messaggio lo genera MPD. Ma il problema credo sia a monte: da qualche parte (che non conosco) ALSA credo decodifichi il dispositivo come audio 10 canali.
Quindi poi MPD non sa come convertire un audio stereo in uno 10 canali.

Alle volte MPD prosegue comunque a eseguire il brano, credo per qualche secondo. Il dac nel display alterna l'indicazione di 44Khz a quella di nessun segnale, come se si sganciasse.

Posso provare ad installare un altro player, cosa dovrei provare?

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Switters il Ven 6 Set 2013 - 9:53

@Menestrello ha scritto:Certo, il messaggio lo genera MPD. Ma il problema credo sia a monte: da qualche parte (che non conosco) ALSA credo decodifichi il dispositivo come audio 10 canali.
Quindi poi MPD non sa come convertire un audio stereo in uno 10 canali.
Magari si può risolvere anche solo modificando mpd.conf o configurando ALSA...
Avendo sotto mano i sorgenti di MPD si potrebbe provare a modificare i sorgenti (PcmChannels.cxx ?) per forzare una delle conversioni disponibili e vedere che succede.

Posso provare ad installare un altro player, cosa dovrei provare?
Oddio, non è che io sia un grande esperto di player linux Very Happy
Prova con aplay, probabilmente è già installato.

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Ven 6 Set 2013 - 10:17

Non so.
A naso mi sembra ci sia qualche problema nel riconoscimento del dispositivo.
Ora sono al lavoro e non riesco a vedere, ma alsamixer per il NAD mi fa vedere 2 cursori che hanno a che fare con il clock. Don't know 
Mi sembrano un po' strani, non trovi?
Comunque una prova con aplay la farò Cool 

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Switters il Ven 6 Set 2013 - 10:37

Ti hanno risposto da NAD?

Continua a rompergli le palle, sul sito dicono:
In order to stream your computer audio via the M51, ensure that the Sound or Audio device setting of your computer is set to "NAD USB Audio 2.0".
Questo per quanto riguarda Windows e OS X, io gli chiederei come si fa a vedere l'M51 come un DAC due canali in Linux... Hehe Hehe Hehe 
Tra l'altro, se ho ben capito, l'interfaccia USB è XMOS, dovrebbe essere supportata nativamente da Linux.

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: Linux e M51?

Messaggio  Menestrello il Ven 6 Set 2013 - 10:44

@Switters ha scritto:Ti hanno risposto da NAD?
re: DAC M51 USB 2.0
Thank you for contacting the NAD Electronics Support Centre.

Currently, the M51 USB connection isn't supported by Linux. However, there are plans to look at this in the future.

Sorry for any inconvenience this may cause you.


Che è la stessa risposta che davano un anno fa Shut up 
A questo punto preferirei indagare da me se trovo qualcuno che si intende di mpd/alsa.
La cosa che mi fa rabbia è che su macchine Apple viene riconosciuto senza problemi Mad 
Ne deduco che il problema non è del NAD ma dei driver in linux, no?

Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Tornare in alto Andare in basso

Pagina 2 di 3 Precedente  1, 2, 3  Seguente

Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto

- Argomenti simili

 
Permesso di questo forum:
Non puoi rispondere agli argomenti in questo forum