T-Forum, la vera HiFi alla portata di tutti
Benvenuto nel T-Forum!
Connettiti in modo da farti riconoscere come membro affezionato, oppure registrati così potrai partecipare attivamente alle discussioni.
Ultimi argomenti
» AudioNirvana Super 12" Cast Frame in cabinet 5.6MKII - risultato finale
Oggi alle 19:07 Da lello64

» Diffusori da scaffale per primo impianto
Oggi alle 19:00 Da PietroM84

» ciò solo 200 euri.... le scinte e il cinesino.... oppure...
Oggi alle 18:51 Da mumps

» Consigli audio pc
Oggi alle 18:45 Da Yrneb9

» DIY Sb acoustic e Fabrix di Audiojam
Oggi alle 18:27 Da giucam61

» Dac Gustard X20 rapporto prezzo prestazioni stellare.
Oggi alle 18:20 Da giucam61

» [Vendo] Nad C316BEE €210
Oggi alle 17:40 Da Dreammachine

» Celestion Ditton 150
Oggi alle 16:43 Da potowatax

» Alva Noto and Ryuichi Sakamoto - Berlin
Oggi alle 15:54 Da sportyerre

» T-preamp si spegne con l'elettricità statica
Oggi alle 15:24 Da fuzzu82

» consiglio diffusori pavimento
Oggi alle 15:24 Da mumps

» primo impianto hifi
Oggi alle 15:13 Da fabe-r

» lettura file SACD compattati
Oggi alle 14:38 Da PCHIO

» Help nabbo alle prime armi! Sony PS-LX300USB
Oggi alle 14:23 Da DavideF

» Consiglio nuova scheda audio
Oggi alle 13:59 Da potowatax

» Dodocool DA106 di nuovo disponibile, con sconto
Oggi alle 13:47 Da diechirico

» Consiglio Diffusori Vintage
Oggi alle 11:06 Da portnoy1965

» Info alimentatore switching
Ieri alle 21:32 Da Albert^ONE

» [VENDUTO] [VICENZA/ITALIA] Beresford Bushmaster MKII - 150€
Ieri alle 18:38 Da Wordcrasher

» costruire nuova cassa per subwoofer
Ieri alle 17:52 Da vds

» FX Audio D802, cambio alimentatore e relazione V e W
Ieri alle 17:28 Da pim

» AR3a
Ieri alle 17:01 Da asimmetrico

» amplificatore 2 telai gainclone
Ieri alle 15:41 Da Renzo Badiale

» Quali casse da controsoffitto?
Ieri alle 15:11 Da Gianni S

» black sabbath - ten year war - flac 24/96
Ieri alle 14:21 Da mumps

» Ampli+DAC Audio-GD R2R 11
Ieri alle 12:00 Da Saxabar

» CONSIGLIO PER UN FINALE PER TISBURY AUDIO PREAMPLI LINEA PASSIVO
Ieri alle 11:09 Da cicop

» preamp economico per spotify?
Ieri alle 10:32 Da Saxabar

» t-amp ...fritto ?
Ieri alle 9:47 Da marco_54

» DAC e casse 2.1
Ieri alle 8:52 Da mumps

Statistiche
Abbiamo 11343 membri registrati
L'ultimo utente registrato è freeride

I nostri membri hanno inviato un totale di 805320 messaggi in 52215 argomenti
I postatori più attivi della settimana
lello64
 
mumps
 
pim
 
PietroM84
 
DavideF
 
Masterix
 
giucam61
 
Pinve
 
sportyerre
 
Saxabar
 

Migliori postatori
Stentor (20392)
 
DACCLOR65 (19633)
 
schwantz34 (15535)
 
Silver Black (15501)
 
nd1967 (12803)
 
flovato (12509)
 
Biagio De Simone (10287)
 
piero7 (9854)
 
fritznet (9336)
 
wasky (9229)
 

Chi è in linea
In totale ci sono 90 utenti in linea: 16 Registrati, 1 Nascosto e 73 Ospiti :: 2 Motori di ricerca

alephotos, dieggs, franzfranz, Giovanni_14, kalium, lello64, Masterix, PietroM84, potowatax, Rino88ex, scontin, silver surfer, Telstar, valterneri, Yrneb9, Zio

[ Vedere la lista completa ]


Il numero massimo di utenti online contemporaneamente è stato 4379 il Lun 25 Mag 2015 - 15:01
Flusso RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 


Bookmarking sociale

Bookmarking sociale digg  Bookmarking sociale delicious  Bookmarking sociale reddit  Bookmarking sociale stumbleupon  Bookmarking sociale slashdot  Bookmarking sociale yahoo  Bookmarking sociale google  Bookmarking sociale blogmarks  Bookmarking sociale live      




Conserva e condividi l'indirizzo di T-Forum, la vera HiFi alla portata di tutti sul tuo sito sociale bookmarking


lighttpd con MPD qualcuno lo usa?

Pagina 2 di 2 Precedente  1, 2

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Sab 12 Ott 2013 - 20:18

Ho trovato una guida su internet per nginx e MpDroid.
Ddato che ho installato anche nginx ed è settato sulla porta 80 mi son detto che forse è meglio impostare quello invece di ravanare con lighttpd Smile
La guida è a questo indirizzo

New nginx install
For a new nginx install, copy the below into a new file at /etc/nginx/sites-available/mpd-cover-art.conf:

Codice:
server {
    listen 80;
    server_name 192.168.1.102;

    location /cover-art/ {
        root /home/mafrosis/MP3/;
        rewrite /cover-art/(.*) /$1 break;
        try_files $uri $uri;
        allow   192.168.1.0/24;
        deny    all;
    }
}
Now run the following commands to get nginx to pick up the new config:

Codice:
$ sudo rm /etc/nginx/sites-enabled/mpd-cover-art.conf
$ sudo ln -s /etc/nginx/sites-available/mpd-cover-art.conf /etc/nginx/sites-enabled/
$ sudo /etc/init.d/nginx restart
ho provato questa operazione ma non funziona ancora.
Qualcuno ci capisce qualcosa?

Ho notato che il valore allow è impostato su 192.168.1.0/24; non capisco cosa sia quel 24 dopo lo slash.

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  maggio il Sab 12 Ott 2013 - 20:36

@andreaea ha scritto:

a questo punto da quanto ho capito ho installato nginx, ma allora perchè non me lo rimuove quando faccio apt-get remove nginx?
Devi fermare nginx per poterlo rimuovere, leggi bene la parte iniziale del post.
Ciao

maggio
Novizio
Novizio

Data d'iscrizione : 03.12.12
Numero di messaggi : 11
Località : Bergamo
Impianto : (non specificato)

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Sab 12 Ott 2013 - 20:46

allora, ricapitoliamo,
io faccio
/etc/init.d/nginx stop
e viene stoppato nginx
poi faccio
apt-get remove nginx
ma ottengo
Package 'nginx' is not installed, so not removed

a questo punto non ci capisco nulla, se tento di disinstallarlo mi dice che non è installato, ma se controllo chi occupa la porta 80 è nginx Shocked BOOOOH!

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Sab 12 Ott 2013 - 21:31

Se lancio il comando lsof -i :80 mentre uso MpDroid per comandare la musica, sembra che il server nginx funzioni:
nginx TCP 10.10.1.69:http->10.10.1.6(l'IP del mio smartphone):45307 (ESTABILISHED)

se apro un browser dallo smartphone e nella barra degli indirizzi digito:
http://10.10.1.69/
o
10.10.1.69//media/
o
10.10.1.69//media/andy/
o
10.10.1.69//media/andy/Musica
non si apre nulla se non una pagina bianca con "404 not found, nginx 1.2.1"

probabilmente sbaglio qualcosa... Sad

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  maggio il Sab 12 Ott 2013 - 22:58

Disabilita il servizio all'avvio con rcconf.
Poi riavvia. Controlla che il servizio sia fermo e poi segui la guida.
Ciao

maggio
Novizio
Novizio

Data d'iscrizione : 03.12.12
Numero di messaggi : 11
Località : Bergamo
Impianto : (non specificato)

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Switters il Dom 13 Ott 2013 - 0:04

@andreaea ha scritto:Ho notato che il valore allow è impostato su 192.168.1.0/24; non capisco cosa sia quel 24 dopo lo slash.
Il 24 è il numero di bit che individuano la subnet, corrisponde alla netmask 255.255.255.0, vuol dire che tutti i PC che appartengono alla subnet hanno indirizzo 192.168.1.x, nel tuo caso dovrebbe essere 10.10.1.0/24 (anche se, se ben ricordo, gli indirizzi della serie 10. è previsto che abbiano una netmask di 8 o 16. Ma questo è un altro discorso, per te va benissimo il /24).

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Dom 13 Ott 2013 - 9:01

Come faccio a disabilitare il servizio con rcconf?

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  maggio il Dom 13 Ott 2013 - 9:48

Avvii rcconf e ti compare una schermata per configurare l'avvio dei servizi al boot.
Deselezioni quello che vuoi fermare, esci e riavvii.
Ciao

maggio
Novizio
Novizio

Data d'iscrizione : 03.12.12
Numero di messaggi : 11
Località : Bergamo
Impianto : (non specificato)

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Dom 13 Ott 2013 - 10:38

scusa ma come faccio ad avviare rcconf?
io scrivo rcconf da riga di comando ma mi da errore, purtroppo sono un ignorante totale di linux, lo ho scritto qualche post fa Embarassed

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  maggio il Dom 13 Ott 2013 - 11:30

Installa rcconf con:

apt-get install rcconf


Una volta installato, fallo partire digitando "rcconf" sul terminale seguito da "INVIO"



Ciao

maggio
Novizio
Novizio

Data d'iscrizione : 03.12.12
Numero di messaggi : 11
Località : Bergamo
Impianto : (non specificato)

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Dom 13 Ott 2013 - 11:45

fatto
ora come faccio a togliere la spunta dal servizio che non voglio si avii? Embarassed 
GRAZIE!

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Dom 13 Ott 2013 - 11:49

ok, finalmente trovato su san google: barra spaziatrice Smile
avevo provato tutti i tasti e le combinazioni mi mancava solo quella, chi l'avrebbe mai pensato... Laughing

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Dom 13 Ott 2013 - 12:12

FUNZIONA!!
Posto qui il tutto così magari serve a qualcun altro.
Ho disabilitato nginx come consigliato, dopo aver installato rcconf.
Ho attribuito a lighttpd la porta 80.
Ho riavviato..  e funziona!
Sullo smartphone in MpDroid ho impostato il parametro COVER ART SETTINGS -> PATH TO MUSIC su "/" (senza le virgolette).

GRAZIE a tutti quelli che mi hanno aiutato!! Very Happy

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Tornare in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Contenuto sponsorizzato


Contenuto sponsorizzato


Tornare in alto Andare in basso

Pagina 2 di 2 Precedente  1, 2

Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto

- Argomenti simili

 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum