T-Forum, la vera HiFi alla portata di tutti
Benvenuto nel T-Forum!
Connettiti in modo da farti riconoscere come membro affezionato, oppure registrati così potrai partecipare attivamente alle discussioni.
Ultimi argomenti
» tappetino per giradischi
Oggi alle 1:05 Da giucam61

» Consiglio ragionato per upgrade diffusori
Oggi alle 1:04 Da nerone

» (CD)ilemma
Ieri alle 21:07 Da Fabio Menozzi

» [Vendo] Amplificatore cuffie Little Dot 1+ a 90 euro + s.s.
Ieri alle 21:01 Da Nadir81

» Google Home
Ieri alle 17:29 Da ftalien77

» Vinili Usati ? costano come nuovi !
Ieri alle 17:00 Da nerone

» ALIENTEK D8 [parte 2]
Ieri alle 15:14 Da almo70

» Ampli integrato classe AB tra i 500 e i 700 Euro
Ieri alle 14:50 Da danilopace

» Chiarimento su Dac e chromecast audio
Ieri alle 9:54 Da ftalien77

» Consiglio DAC/AMP per AKG K240 mkll
Gio 19 Lug 2018 - 21:35 Da mumps

» Ion Systems Obelisk 100 - amplinglese amato da Joe Akroyd (Royd Audio)
Gio 19 Lug 2018 - 18:52 Da mauz

» vendo cuffie sennheiser hd 598sr
Gio 19 Lug 2018 - 18:44 Da mumps

» Info QED profile audio, WW Luna 7, Mogami W3106 e Mogami W2964
Gio 19 Lug 2018 - 16:24 Da Alex23

» LT+sped) Prephono LesaHifi Archimede
Gio 19 Lug 2018 - 16:04 Da joe1976

» [VENDO] Cavi originali (due) per cuffie Sennheiser HD600 e HD650 a 16 EUR + S.S.
Gio 19 Lug 2018 - 15:49 Da Nadir81

» [Vendo] Grado extension cable originale 4,5 metri - 25 euro + spedizione
Gio 19 Lug 2018 - 15:28 Da Nadir81

» [VENDO] [ROMA/ITALIA] Perreaux SXH2 (Ampli cuffie) - 300€ inclusa spedizione
Gio 19 Lug 2018 - 15:21 Da donluca

» [VENDO] [ROMA/ITALIA] HiFiMan HE-400 (Cuffie) - 250€ spedizione inclusa
Gio 19 Lug 2018 - 15:19 Da donluca

» Che mi dite del Luxman lv-105?
Gio 19 Lug 2018 - 14:11 Da mauretto

» [RG+ sp] Ampl x cuffie Lehmann clone 30€ compreso sped.
Gio 19 Lug 2018 - 11:08 Da sportyerre

» Magnetofono Geloso G681
Mer 18 Lug 2018 - 21:38 Da sportyerre

» Chromecast Audio - Vostre opinioni ed esperienze
Mer 18 Lug 2018 - 15:18 Da ftalien77

» Come sparare da Chromecast AUDIO da NAS (no DLNA) con APP Android
Mer 18 Lug 2018 - 15:14 Da ftalien77

» Hard disk esterno per musica liquida
Mer 18 Lug 2018 - 8:25 Da almo70

» Cyrus one d
Mer 18 Lug 2018 - 7:27 Da GP9

» Comsiglio lettore cd/sacd "top gamma"
Mar 17 Lug 2018 - 16:23 Da gianni1879

» Canton CT-1000............ follia audiofila [mini-recensione]
Mar 17 Lug 2018 - 11:36 Da antimateria

» Vendo amplificatore integrato ibrido Peachtree iNova
Lun 16 Lug 2018 - 22:10 Da p.cristallini

» Cuffie home per pop rock.
Lun 16 Lug 2018 - 21:36 Da Adriano61

» Eliminare Bump
Lun 16 Lug 2018 - 17:18 Da Samuele

Statistiche
Abbiamo 11734 membri registrati
L'ultimo utente registrato è il napoletano

I nostri membri hanno inviato un totale di 815871 messaggi in 52966 argomenti
I postatori più attivi della settimana
lello64
 
Nadir81
 
mumps
 
nerone
 
ftalien77
 
antbom
 
Pinve
 
Olegol
 
potowatax
 
almo70
 

Migliori postatori
Stentor (20392)
 
DACCLOR65 (19633)
 
schwantz34 (15631)
 
Silver Black (15543)
 
nd1967 (12810)
 
flovato (12509)
 
Biagio De Simone (10302)
 
piero7 (9854)
 
fritznet (9642)
 
wasky (9229)
 

Chi è online?
In totale ci sono 35 utenti in linea: 4 Registrati, 0 Nascosti e 31 Ospiti :: 2 Motori di ricerca

brico, mumps, Nadir81, nerone

[ Vedere la lista completa ]


Il numero massimo di utenti online contemporaneamente è stato 4379 il Lun 25 Mag 2015 - 15:01
Flusso RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 


Bookmarking sociale

Bookmarking sociale digg  Bookmarking sociale delicious  Bookmarking sociale reddit  Bookmarking sociale stumbleupon  Bookmarking sociale slashdot  Bookmarking sociale yahoo  Bookmarking sociale google  Bookmarking sociale blogmarks  Bookmarking sociale live      




Conserva e condividi l'indirizzo di T-Forum, la vera HiFi alla portata di tutti sul tuo sito sociale bookmarking


lighttpd con MPD qualcuno lo usa?

Pagina 1 di 2 1, 2  Seguente

Andare in basso

lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Sab 29 Giu 2013 - 10:57

Ciao, volevo sapere come settare le directory con
lighttpd per poter vedere le copertine degli Lp usando voyage mpd comandato da MPDroid. al momento ho fatto un sacco di tentativi ma senza riuscire
grazie per l'aiuto

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Gio 11 Lug 2013 - 15:41

mi permetto di riportare all'attenzione la domanda che pstai qualche tempo fa

qualcuno sa come settare le directory con lighttpd per poter vedere le copertine degli Lp usando voyage mpd comandato da MPDroid?
grazie 1000!


andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  alexdz il Ven 12 Lug 2013 - 9:21

Ciao, forse questa guida puo' tornarti utile.


alexdz
Interessato
Interessato

Data d'iscrizione : 23.08.12
Numero di messaggi : 88
Provincia (Città) : Vicenza
Impianto : Sorgenti: Sony CDP-790, Rpi2+MPD+IQAudio DAC+ - Amplificatore: Sony TA-F210 - Casse: Indiana Line 022 - Cuffie: Audio Technica Pro ATH-M40X, Sennheiser HD201


Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Vella il Ven 12 Lug 2013 - 9:46

Io lo uso con Ipad e Mpad.
Se non ricordo male, c'è un file di conf in qui devi specificare le directory da condividere. E poi dare al client l'indirizzo ip del pc su cui hai messo lighttpd.

M forse lo sapevi già...
avatar
Vella
Membro classe argento
Membro classe argento

Data d'iscrizione : 29.12.10
Numero di messaggi : 3992
Località : Milano
Occupazione/Hobby : finanza/tra un pò scrivo un romanzo
Impianto :
Spoiler:
Asus eeebox+Lubuntu/MPD - Rega Planet 2000 - Benchmark DAC1USB - Electrocompaniet EC3 - Electrocompaniet AW 120 DMB - Duevel Planets - Sennheiser HD600
Chord USB Silver Plus - Mogami 2964 - Atlas Element Integra - WireWorld Stratus 5(2) - QED Anniversary Silver XT Anniversary


Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Menestrello il Ven 12 Lug 2013 - 9:54

Io ho lighttpd installato e configurato.
Ora non posso accedere al file di configurazione per fare un controllo, ma non mi funziona con Ipad+mpad.
Invece con il programma su Android (che si chiama MPD? non ricordo) funziona perfettamente.
Mistero...
(Se state per dire che MPAD è configurato male vi sbagliate Scream )
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Vella il Ven 12 Lug 2013 - 10:40

@Menestrello ha scritto:Io ho lighttpd installato e configurato.
Ora non posso accedere al file di configurazione per fare un controllo, ma non mi funziona con Ipad+mpad.
Invece con il programma su Android  (che si chiama MPD? non ricordo) funziona perfettamente.
Mistero...
(Se state per dire che MPAD è configurato male vi sbagliate Scream )

Con Ipad-Mpad all'inizio anch'io ho tirato giù quei 4-500 santi assortiti.
Poi però entrando in Cover Wizard, tastino che ti compare quando selezioni un album e ti esce la lista dei brani (sotto il tastino Suona tutto l'album, non mi ricordo come è scritto in inglese), lì avevo visto che Mpad puntava ad un indirizzo ip sbagliato per cercarsi le copertine.

Ora funziona 'na meraviglia, forse hai Mpad configurato male!!!!!
avatar
Vella
Membro classe argento
Membro classe argento

Data d'iscrizione : 29.12.10
Numero di messaggi : 3992
Località : Milano
Occupazione/Hobby : finanza/tra un pò scrivo un romanzo
Impianto :
Spoiler:
Asus eeebox+Lubuntu/MPD - Rega Planet 2000 - Benchmark DAC1USB - Electrocompaniet EC3 - Electrocompaniet AW 120 DMB - Duevel Planets - Sennheiser HD600
Chord USB Silver Plus - Mogami 2964 - Atlas Element Integra - WireWorld Stratus 5(2) - QED Anniversary Silver XT Anniversary


Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Menestrello il Ven 12 Lug 2013 - 10:42

@Vella ha scritto:
@Menestrello ha scritto:Io ho lighttpd installato e configurato.
Ora non posso accedere al file di configurazione per fare un controllo, ma non mi funziona con Ipad+mpad.
Invece con il programma su Android  (che si chiama MPD? non ricordo) funziona perfettamente.
Mistero...
(Se state per dire che MPAD è configurato male vi sbagliate Scream )

Con Ipad-Mpad all'inizio anch'io ho tirato giù quei 4-500 santi assortiti.
Poi però entrando in Cover Wizard, tastino che ti compare quando selezioni un album e ti esce la lista dei brani (sotto il tastino Suona tutto l'album, non mi ricordo come è scritto in inglese), lì avevo visto che Mpad puntava ad un indirizzo ip sbagliato per cercarsi le copertine.

Ora funziona 'na meraviglia, forse hai Mpad configurato male!!!!!

Tu cerchi rogne Mad 


Hehe Hehe Hehe Hehe 

Ti pare che non ho premuto il tastino, verificato il link scrivendolo a manina santa sul browser visto che non è copincollabile e smoccolato perché nel browser funziona? Laughing

Prima o poi farò altri controlli, per ora va bene così Very Happy 
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Vella il Ven 12 Lug 2013 - 11:03

@Menestrello ha scritto:
Tu cerchi rogne Mad 


Hehe Hehe Hehe Hehe 

Ti pare che non ho premuto il tastino, verificato il link scrivendolo a manina santa sul browser visto che non è copincollabile e smoccolato perché nel browser funziona? Laughing

Prima o poi farò altri controlli, per ora va bene così Very Happy 

Maaaaaaaaammaaaaaa mia che brutto carattere!!!!!!!!!
avatar
Vella
Membro classe argento
Membro classe argento

Data d'iscrizione : 29.12.10
Numero di messaggi : 3992
Località : Milano
Occupazione/Hobby : finanza/tra un pò scrivo un romanzo
Impianto :
Spoiler:
Asus eeebox+Lubuntu/MPD - Rega Planet 2000 - Benchmark DAC1USB - Electrocompaniet EC3 - Electrocompaniet AW 120 DMB - Duevel Planets - Sennheiser HD600
Chord USB Silver Plus - Mogami 2964 - Atlas Element Integra - WireWorld Stratus 5(2) - QED Anniversary Silver XT Anniversary


Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Menestrello il Ven 12 Lug 2013 - 11:09

@Vella ha scritto:
@Menestrello ha scritto:
Tu cerchi rogne Mad 


Hehe Hehe Hehe Hehe 

Ti pare che non ho premuto il tastino, verificato il link scrivendolo a manina santa sul browser visto che non è copincollabile e smoccolato perché nel browser funziona? Laughing

Prima o poi farò altri controlli, per ora va bene così Very Happy 

Maaaaaaaaammaaaaaa mia che brutto carattere!!!!!!!!!

Eppure l'avevo scritto: "(Se state per dire che MPAD è configurato male vi sbagliate )"
Suspect 


Ho bisogno di ferie Very Happy Very Happy Very Happy Very Happy 


Kiss 
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Vella il Ven 12 Lug 2013 - 11:46

@Menestrello ha scritto:

Eppure l'avevo scritto: "(Se state per dire che MPAD è configurato male vi sbagliate  )"
Suspect 


Ho bisogno di ferie Very Happy Very Happy Very Happy Very Happy 


Kiss 

E apposta l'ho ribadito. Ci ho messo pure i punti esclamativi!!!
Anch'io ne ho bisogno, disperatamente!
avatar
Vella
Membro classe argento
Membro classe argento

Data d'iscrizione : 29.12.10
Numero di messaggi : 3992
Località : Milano
Occupazione/Hobby : finanza/tra un pò scrivo un romanzo
Impianto :
Spoiler:
Asus eeebox+Lubuntu/MPD - Rega Planet 2000 - Benchmark DAC1USB - Electrocompaniet EC3 - Electrocompaniet AW 120 DMB - Duevel Planets - Sennheiser HD600
Chord USB Silver Plus - Mogami 2964 - Atlas Element Integra - WireWorld Stratus 5(2) - QED Anniversary Silver XT Anniversary


Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Menestrello il Ven 12 Lug 2013 - 11:51

Comunque, per tornare in tema, è molto strano questo comportamento.
Devo rivedere il file di configurazione di lighttpd ma non trovo mai il tempo Sad 
Visto che questo weekend lo passerò a preparare i bagagli, penso che oramai se ne riparlerà al ritorno dalla Sardegna, dopo Ferragosto Very Happy Very Happy Very Happy Very Happy Cool 

avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Gio 22 Ago 2013 - 9:55

@alexdz ha scritto:Ciao, forse questa guida puo' tornarti utile.
Ciao e grazie 1000 per il link.
Ho provato a impostare i valori come da guida ma non funziona.
Credo di aver compilato correttamente il file /etc/lighttpd/lighttpd.conf come spiegato nella guida.
Il problema è che purtroppo non mi è chiaro a che voce del client MPdroid devo inserire l'indirizzo IP del server e la porta sulla quale lighttpd è in ascolto (nel mio caso 10.10.1.68:90): forse alla voce COVER ART SETTINGS / PATH TO MUSIC?

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Mer 11 Set 2013 - 0:46

mi permetto driportare all'attivo la discussione, magari qualcuno che è ritornato dalle ferie conosce la maniera di impostare nel modo giusto
grazie

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Sab 12 Ott 2013 - 9:41

qualcuno mi sa aiutare?

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Menestrello il Sab 12 Ott 2013 - 10:30

@andreaea ha scritto:
@alexdz ha scritto:Ciao, forse questa guida puo' tornarti utile.
Ciao e grazie 1000 per il link.
Ho provato a impostare i valori come da guida ma non funziona.
Credo di aver compilato correttamente il file /etc/lighttpd/lighttpd.conf come spiegato nella guida.
Il problema è che purtroppo non mi è chiaro a che voce del client MPdroid devo inserire l'indirizzo IP del server e la porta sulla quale lighttpd è in ascolto (nel mio caso 10.10.1.68:90): forse alla voce COVER ART SETTINGS / PATH TO MUSIC?
Mi sembra la voce giusta.
Piuttosto, perché usi la porta 90 per il server lighttpd?
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Sab 12 Ott 2013 - 13:44

ciao, quando ho installato lighttpd nel file di configurazione di default la porta era la 80, però quando ho riavviato ho notato che quando veniva caricato lighttpd ottenevp un errore che diceva che la porta 80 era già in uso e allora la ho modificata.
Sbaglio qualcosa?

In questo forum mi hanno detto di impostare il parametro COVER ART SETTINGS / PATH TO MUSIC su "/" (senza le virgolette) ma nemmeno così funziona.

Ogni aiuto è altamente gradito!

grazie

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Menestrello il Sab 12 Ott 2013 - 14:14

se ti dice che è in uso devi chiederti perché Wink

Forse hai già apache o un altro web server?
Che cosa usi (macchina, distribuzioe etc)?

Poi dovresti riportare qui mpd.conf, non tutto ma solo la parte relativa al path con la musica.
E lighttpd.conf

@andreaea ha scritto:ciao, quando ho installato lighttpd nel file di configurazione di default la porta era la 80, però quando ho riavviato ho notato che quando veniva caricato lighttpd ottenevp un errore che diceva che la porta 80 era già in uso e allora la ho modificata.
Sbaglio qualcosa?

In questo forum mi hanno detto di impostare il parametro COVER ART SETTINGS / PATH TO MUSIC su "/" (senza le virgolette) ma nemmeno così funziona.

Ogni aiuto è altamente gradito!

grazie
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Sab 12 Ott 2013 - 14:35

le impostazioni sono:

/etc/mpd.conf
bind_to_address "10.10.1.69"
port 6600
music_directory "/media/andy/Musica"


/etc/lighttpd/lighttpd.conf
server.port = 90
server.document-root = "/media/andy/Musica"


la questione della porta occupata è strana, perchè quando edito il file lighttpd.conf, prima stoppo il server, poi modifico la porta (ad es. 86), poi riavvio il server e mi dice che quella porta è occupata.

Non credo di avere altri server installati ma non lo so, ho effettuato una installazione di Voyage MPD seguendo questa guida.
Purtroppo ci capisco veramente nulla di linux Sad

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Menestrello il Sab 12 Ott 2013 - 15:04

Mi sembra vada tutto bene, tranne la questione della porta 80/90.
Sevi mapparlo sulla porta 80, perché non credo tu riesca a configurare per la 90 MPDroid
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Sab 12 Ott 2013 - 15:31

@Menestrello ha scritto:...devi mapparlo sulla porta 80, perché non credo tu riesca a configurare per la 90 MPDroid
Per favore mi potresti dire come fare a mapparlo per la porta 80?
Come potrei fare a vedere "cosa" mi occupa la porta 80 attualmente (immagino che se lighttpd mi dice che è occupata ci sia un programma che la occupa).
GRAZIE!

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Menestrello il Sab 12 Ott 2013 - 16:07

@andreaea ha scritto:
@Menestrello ha scritto:...devi mapparlo sulla porta 80, perché non credo tu riesca a configurare per la 90 MPDroid
Per favore mi potresti dire come fare a mapparlo per la porta 80?
Come potrei fare a vedere "cosa" mi occupa la porta 80 attualmente (immagino che se lighttpd mi dice che è occupata ci sia un programma che la occupa).
GRAZIE!
Non so dirti come trovare il programma che occupa la porta 80 Don't know 
Che Linux hai?
Per riconfigurare lighttpd basta che cambi 90 con 80, ovviamente, e lo fai ripartire.
Very Happy 
avatar
Menestrello
Membro classe argento
Membro classe argento

Data d'iscrizione : 24.01.11
Numero di messaggi : 3131
Località : Empoli
Occupazione/Hobby : Vado a scquola
Provincia (Città) : molesto
Impianto : bacato

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Sab 12 Ott 2013 - 17:31

io ho installato voyage mpd.
ho provato ad impostare lighttpd con la porta 80 (editando il file conf) ma, come dicevo. ma quando lo riavvio mi dice che è già occupata

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  maggio il Sab 12 Ott 2013 - 18:24

Prova a seguire passo passo questa guida:

netstat -tap
Disinstallate "nfs-common"  e "nginx" (o disabilitate i servizi all'avvio con "rcconf") che potrebbero creare problemi di compatibilità

Controllare che nginx e tutti i www siano fermi (in caso fermarli)
netstat -tap

apt-get remove nfs-common nginx

Installate il programma "lighttpd"
apt-get install lighttpd

Prima di configurare "lighttpd", fermiamolo col comando
/etc/init.d/lighttpd stop

Configuriamo ora "lighttpd" col comando
nano /etc/lighttpd/lighttpd.conf

Modificate le seguenti righe del file di configurazione come segue, avendo cura di selezionare la cartella/directory dove tenete la vostra musica (server.document-root) e quella dell'upload (server.upload-dirs); inoltre dovete commentare (inserire "#" cancelletto ad inizio riga) "server.username" e "server.groupname"


server.document-root        = "/media/cb/musica"
server.upload-dirs          = ( "/media/cb" )
#server.username             = "www-data"
#server.groupname            = "www-data"


Mi raccomando, quando indicate al web server lighttpd la cartella "server.document-root"  dove si trova la vostra musica, accertatevi che sia esattamente identica a quella che avete indicato nel file di configurazione di MPD "/etc/mpd.conf" (music_directory).

Rimuovere Apache2
apt-get remove apache2*

Riavviate "lighttpd" col comando
/etc/init.d/lighttpd start

e poi
/etc/init.d/lighttpd force-reload

Sul client MPoD o MPaD sarà necessario inserire l'indirizzo IP del server e la porta sulla quale lighttpd è in ascolto (se non avete cambiato nulla, quella di default è la 80) e il nome del file/cover art di cui sopra (es.: http://192.168.1.2:80  e "Folder.jpg").

Modificare impo Mpod

Ciao

maggio
Novizio
Novizio

Data d'iscrizione : 03.12.12
Numero di messaggi : 11
Località : Bergamo
Impianto : (non specificato)

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Switters il Sab 12 Ott 2013 - 19:17

Per sapere quale programma ha aperto la porta 80 si può usare anche il comando "lsof":
lsof -i :80

Switters
Membro classe oro
Membro classe oro

Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...


Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  andreaea il Sab 12 Ott 2013 - 19:41

ciao, e grazie per gli aiuti

allora ho provato con i comandi apt-get remove nfs-common nginx e apt-get remove apache2*
ma mi dice che non ci sono installati
però se eseguo netstat -tap nella lista vedo tra gli altri:
Local Address *:domain
State LISTEN
Program name 3152/nginx

e se provo lsof -i :80 come ha consigliato Switters ottengo:
COMMAND nginx
PID 3152
USER root
NODE tcp
NAME *:http (LISTEN)

a questo punto da quanto ho capito ho installato nginx, ma allora perchè non me lo rimuove quando faccio apt-get remove nginx?

andreaea
Interessato
Interessato

Data d'iscrizione : 19.05.12
Numero di messaggi : 57
Località : Milano
Provincia (Città) : allegro con Brie
Impianto : Amplificatore X + Casse Y

Torna in alto Andare in basso

Re: lighttpd con MPD qualcuno lo usa?

Messaggio  Contenuto sponsorizzato


Contenuto sponsorizzato


Torna in alto Andare in basso

Pagina 1 di 2 1, 2  Seguente

Torna in alto

- Argomenti simili

 
Permessi di questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum