T-Forum, la vera HiFi alla portata di tutti
Benvenuto nel T-Forum!
Connettiti in modo da farti riconoscere come membro affezionato, oppure registrati così potrai partecipare attivamente alle discussioni.
Ultimi argomenti
queOggi alle 0:54Allen smithee
POPU VENUS Ieri alle 19:05giucam61
Smsl ad18Mer 22 Mar 2017 - 19:57MaxDrou
(NA) Triangle MimimunMer 22 Mar 2017 - 13:17sonic63
ALIENTEK D8Mar 21 Mar 2017 - 21:03Luca Marchetti
Posso usare un ta 2024 Mar 21 Mar 2017 - 20:12RAIS
PC per la musicaMar 21 Mar 2017 - 17:45Snap
Vendo Cayin 220 CUMar 21 Mar 2017 - 15:22wolfman
[ARGHHH!!!] ;)Mar 21 Mar 2017 - 15:09Alessandro Marchese
Nad 1000 o nad c350Mar 21 Mar 2017 - 10:24Motogiullare
(RM) Cuffie Nad Viso hp50Lun 20 Mar 2017 - 23:20kocozze
US3, mi aiutate?Lun 20 Mar 2017 - 21:41vinse
Gabris amp CalypsoLun 20 Mar 2017 - 19:54natale55
Sondaggio
Ti piace il nuovo stile del T-Forum?
Sì, meglio questo nuovo
58% / 11
No, era meglio quello vecchio
42% / 8
I postatori più attivi della settimana
51 Messaggi - 23%
48 Messaggi - 22%
36 Messaggi - 16%
17 Messaggi - 8%
16 Messaggi - 7%
12 Messaggi - 5%
11 Messaggi - 5%
10 Messaggi - 5%
10 Messaggi - 5%
10 Messaggi - 5%
I postatori più attivi del mese
249 Messaggi - 21%
221 Messaggi - 19%
142 Messaggi - 12%
126 Messaggi - 11%
100 Messaggi - 9%
72 Messaggi - 6%
71 Messaggi - 6%
68 Messaggi - 6%
62 Messaggi - 5%
61 Messaggi - 5%
Migliori postatori
Stentor (20392)
20392 Messaggi - 15%
DACCLOR65 (19630)
19630 Messaggi - 15%
schwantz34 (15499)
15499 Messaggi - 12%
Silver Black (15427)
15427 Messaggi - 11%
nd1967 (12803)
12803 Messaggi - 10%
flovato (12509)
12509 Messaggi - 9%
10260 Messaggi - 8%
piero7 (9854)
9854 Messaggi - 7%
wasky (9229)
9229 Messaggi - 7%
fritznet (8852)
8852 Messaggi - 7%
Chi è in linea
In totale ci sono 29 utenti in linea :: 2 Registrati, 0 Nascosti e 27 Ospiti :: 2 Motori di ricerca

Alessandro Asborno, p.cristallini

Vedere la lista completa

Flusso RSS

Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 
Bookmarking sociale
Bookmarking sociale Digg  Bookmarking sociale Delicious  Bookmarking sociale Reddit  Bookmarking sociale Stumbleupon  Bookmarking sociale Slashdot  Bookmarking sociale Yahoo  Bookmarking sociale Google  Bookmarking sociale Blinklist  Bookmarking sociale Blogmarks  Bookmarking sociale Technorati  




Conserva e condividi l'indirizzo di T-Forum, la vera HiFi alla portata di tutti sul tuo sito sociale bookmarking
Condividere
Vedere l'argomento precedenteAndare in bassoVedere l'argomento seguente
avatar
brasa
Interessato
Interessato
Data d'iscrizione : 01.01.11
Numero di messaggi : 77
Località : Roma
Occupazione/Hobby : Informatica, Auto e moto, Audio
Provincia (Città) : :)
Impianto : Amplificatore S.M.S.L. SA-36 ( TA 2024 ) Alimentatore Pincellone + Diffusori KEF Coda 7 + DAC DAC DIR9001 PCM1793 OPA2134 by S.M.S.L. + Musiland Monitor 02 US
http://www.marcobrogi.com

Latenza...non riesco a capire!!

il Lun 28 Feb 2011 - 19:28
Ciao a tutti,
ho letto in lungo ed in largo riguardo ai problemi dovuti alla latenza delle schede audio e di come "risolvere" con asio4all ma quello che non capisco è: Siccome noi non dobbiamo suonare, non dobbiamo produrre musica, citando dal manuale d'uso dei driver asio4all "Quando la latenza non ha importanza
In alcuni casi, ASIO4ALL permette di ottenere un audio perfetto dove i driver di Windows falliscono. Per
cui, gli audiofili preferiscono utilizzare, per le tutte le applicazioni, qualora possibile, l'uscita ASIO al
posto di DirectSound o MME, che nella maggior parte dei casi manipolano troppo i dati audio. In questi
casi, la latenza non ha importanza e gli ingressi audio non sono utilizzati. Naturalmente, è meglio
disattivare tutti gli ingressi ed impostare la dimensione del buffer ASIO al massimo!"

effettivamente...ma a noi che ce ne frega della latenza?? Se un brano ci arriva con un ritardo di tot ms cosa ci cambia?? Perchè è cosi importante??
avatar
lello64
Membro classe oro
Membro classe oro
Data d'iscrizione : 10.06.10
Numero di messaggi : 6049
Provincia (Città) : bologna
Impianto : x+y

Re: Latenza...non riesco a capire!!

il Lun 28 Feb 2011 - 19:48
non credo che in questi ambiti sia ricercata la bassa latenza, tanto più che è consigliato alzare il buffer (il che aumenta la latenza)

credo lo si faccia sopratutto per bypassare per quanto possibile l'audio di windows
avatar
emmeci
Membro classe oro
Membro classe oro
Data d'iscrizione : 11.10.10
Numero di messaggi : 5599
Occupazione/Hobby : Musica, Natura, Fotografia
Provincia (Città) : Roma
Impianto : Miliardi di elettroni che agitandosi... fanno musica!

Re: Latenza...non riesco a capire!!

il Lun 28 Feb 2011 - 20:14
@brasa ha scritto:Ciao a tutti,

effettivamente...ma a noi che ce ne frega della latenza?? Se un brano ci arriva con un ritardo di tot ms cosa ci cambia?? Perchè è cosi importante??

Very Happy E' la prima domanda che mi sono posto anch'io! Ma poi una risposta, nel cervello me la sono pure data: se il ritardo (buffer) è costante...poco male ma sen tempo questo ritardo e discontinuo... male! La decodifica dei dati numerici potrebbe subire parecchie approssimazioni per il continuo intervento dei "codici di correzione d'errore" tanto da restituire un segnale analogico degradato, distorto, non fedele all'originale.
Questo è ciò che ho pensato... avendo qualche esperienza nella trasmissione dei dati numerici, mi è sembrata la più logica.
Ciao Mauro
avatar
brasa
Interessato
Interessato
Data d'iscrizione : 01.01.11
Numero di messaggi : 77
Località : Roma
Occupazione/Hobby : Informatica, Auto e moto, Audio
Provincia (Città) : :)
Impianto : Amplificatore S.M.S.L. SA-36 ( TA 2024 ) Alimentatore Pincellone + Diffusori KEF Coda 7 + DAC DAC DIR9001 PCM1793 OPA2134 by S.M.S.L. + Musiland Monitor 02 US
http://www.marcobrogi.com

Re: Latenza...non riesco a capire!!

il Lun 28 Feb 2011 - 20:47
Ok...ma teoricamente aumentando il buffer degli asio4all la latenza che si forma dovrebbe essere costante o sbaglio?
avatar
emmeci
Membro classe oro
Membro classe oro
Data d'iscrizione : 11.10.10
Numero di messaggi : 5599
Occupazione/Hobby : Musica, Natura, Fotografia
Provincia (Città) : Roma
Impianto : Miliardi di elettroni che agitandosi... fanno musica!

Re: Latenza...non riesco a capire!!

il Lun 28 Feb 2011 - 21:11
@brasa ha scritto:Ok...ma teoricamente aumentando il buffer degli asio4all la latenza che si forma dovrebbe essere costante o sbaglio?

Muble Ma... penso che mantenendo il buffer più piccolo possibile, almeno che non si sentano degradi evidenti del segnale ed aumentando i controlli di latenza si ottenga il risultato migliore.
Sicuramente ci sono persone più preparate del sottoscritto che meglio potranno spiegarti.
Ciao mauro
avatar
brasa
Interessato
Interessato
Data d'iscrizione : 01.01.11
Numero di messaggi : 77
Località : Roma
Occupazione/Hobby : Informatica, Auto e moto, Audio
Provincia (Città) : :)
Impianto : Amplificatore S.M.S.L. SA-36 ( TA 2024 ) Alimentatore Pincellone + Diffusori KEF Coda 7 + DAC DAC DIR9001 PCM1793 OPA2134 by S.M.S.L. + Musiland Monitor 02 US
http://www.marcobrogi.com

Re: Latenza...non riesco a capire!!

il Lun 28 Feb 2011 - 21:15
Sarà ma vista la frase scritta da coloro che lo hanno " inventato " mi sembra molto strano...sul loro manuale dicono che per uso audiofilo di ascolto è consigliato spegnere l'ingresso e mettere il buffer al massimo...se non lo sanno loro Wink
avatar
icsnerdics
Membro di riguardo
Membro di riguardo
Data d'iscrizione : 03.01.10
Numero di messaggi : 700
Località : Roma/Fermo
Occupazione/Hobby : multimediaengineering skateboarding l'uncinetto
Provincia (Città) : u' more. bone.
Impianto : /dev/null

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 0:04
@brasa ha scritto:Ok...ma teoricamente aumentando il buffer degli asio4all la latenza che si forma dovrebbe essere costante o sbaglio?

sbagli, ci sono concetti molto complessi dietro queste problematiche, esempio banale, un buffer troppo grande, si svuota completamente in un colpo solo, questo implica un ritardo di svuotamento e un successivo tempo di riempimento, da questo semplice esempio puoi porti il problema di quanto dovrà essere grande un buffer per far si che io abbia una quantità di informazioni in fase notevole evitando però un ritardo di propagazione dell'informazione?
questi concetti si applicano a qualsiasi linea di trasmissione bufferizzata digitale che esista, dai router, ai ADC/DAC, ai sistemi di controllo dei missili radiocomandati . Twisted Evil
avatar
emmeci
Membro classe oro
Membro classe oro
Data d'iscrizione : 11.10.10
Numero di messaggi : 5599
Occupazione/Hobby : Musica, Natura, Fotografia
Provincia (Città) : Roma
Impianto : Miliardi di elettroni che agitandosi... fanno musica!

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 9:19
@icsnerdics ha scritto:
@brasa ha scritto:Ok...ma teoricamente aumentando il buffer degli asio4all la latenza che si forma dovrebbe essere costante o sbaglio?

sbagli, ci sono concetti molto complessi dietro queste problematiche, esempio banale, un buffer troppo grande, si svuota completamente in un colpo solo, questo implica un ritardo di svuotamento e un successivo tempo di riempimento, da questo semplice esempio puoi porti il problema di quanto dovrà essere grande un buffer per far si che io abbia una quantità di informazioni in fase notevole evitando però un ritardo di propagazione dell'informazione?
questi concetti si applicano a qualsiasi linea di trasmissione bufferizzata digitale che esista, dai router, ai ADC/DAC, ai sistemi di controllo dei missili radiocomandati . Twisted Evil

Oki Ecco... così è spiegato decisamente meglio... il concetto che tentavo di esprimere!
Ciao Mauro
avatar
wasky
Moderatore di sezione
Moderatore di sezione
Data d'iscrizione : 03.07.09
Numero di messaggi : 9229
Località : Roma
Occupazione/Hobby : Fancazzista Serio
Provincia (Città) : Come il fiore del ciliegio è il migliore tra i fiori, così, il guerriero è il migliore tra gli uomini
Impianto : Amplifon
http://www.kitaudiopro.com

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 9:31
Ma come parlano quelli di Asio4All di audiofilo ? Crying or Very sad


_________________
"Sentire non è altro che una facoltà permessa da uno dei nostri cinque sensi ma ascoltare è un'arte."   Frank Tyger
Switters
Membro classe oro
Membro classe oro
Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 10:14
Non entro nel merito del caso specifico perché non so come il buffer sia implementato e utilizzato nel caso dei driver asio04all, ma in generale un buffer è un "deposito" che sta in mezzo tra un producer e un consumer di dati (forse un'analogia valida in campo elettrico potrebbe essere un condensatore, ma data la mia ignoranza nel campo potrei avere appena detto una cavolata), da una parte qualcuno deposita nel buffer i dati che qualcun'altro preleva e "consuma". Producer e consumer sono normalmente due processi (o thread di esecuzione) distinti che lavorano in parallelo, mentre il primo accoda i dati nel buffer il secondo li preleva (normalmente secondo una logica FIFO, il primo dato depositato è il primo ad essere prelevato). Scopo del buffer solitamente è quello di riuscire ad alimentare costantemente il consumer e di non lasciarlo mai a corto di dati, se il buffer è grande il producer impiegherà più tempo a riempirlo all'inizio, ci sarà quindi un ritardo nella partenza del consumer (che aspetta che il producer abbia riempito completamente il buffer prima di inizaire a prelevare i dati). Il buffer underrun (o underflow) si verifica quando il consumer preleva dati a una velocità maggiore di quella a cui il producer li deposita, questo può capitare se i dati devono essere letti da disco e il disco è utilizzato da altri processi (giusto per fare un esempio una scansione antivirus o una copia di file di dimensioni ragguardevoli).

Spero di essermi capito... Smile
avatar
brasa
Interessato
Interessato
Data d'iscrizione : 01.01.11
Numero di messaggi : 77
Località : Roma
Occupazione/Hobby : Informatica, Auto e moto, Audio
Provincia (Città) : :)
Impianto : Amplificatore S.M.S.L. SA-36 ( TA 2024 ) Alimentatore Pincellone + Diffusori KEF Coda 7 + DAC DAC DIR9001 PCM1793 OPA2134 by S.M.S.L. + Musiland Monitor 02 US
http://www.marcobrogi.com

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 11:27
Ok quindi quello che ora non riesco a capire è:
perchè con i driver asio4all non riesco a far stare il buffer sotto i 1024 campioni per i file a 16bit e al massimo per ascoltare quelli a 24bit senza preoccuparmi di rumoracci strani mentre ora ho installato i driver kxaudio con supporto asio per la mia scheda audio ( Sb Live! Sad collegata in spdif a dac esterno ) e riesco a configurarla addirittura a 32 campioni senza aver nessun problema? Funzionano male gli asio4all o i kxaudio mi illudono ma funzionano come vogliono loro??

Allego lo screenshot dei kxaudio

toti
Affezionato
Affezionato
Data d'iscrizione : 23.02.10
Numero di messaggi : 190
Località : Catania
Provincia (Città) : Coseno rialzato
Impianto : In ristrutturazione...

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 11:42
Io lo spiego così, gli ASIO4ALL sono driver generici, i kX Project sono specifici per i chipset EMU10Kx, quindi sfrutteranno chiamate hardware dirette.
Switters
Membro classe oro
Membro classe oro
Data d'iscrizione : 24.02.11
Numero di messaggi : 5072
Località : Milano
Provincia (Città) : Milano
Impianto : solo stereo, non HiFi...

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 11:52
Condivido. A naso direi anch'io che il driver kx ASIO vede la scheda in maniera nativa mentre asio4all no. Ma prendila come ipotesi, non conosco né l'uno né l'altro...

Domanda: asio4all non ti dice come vede la scheda o se la scheda è ASIO?
avatar
brasa
Interessato
Interessato
Data d'iscrizione : 01.01.11
Numero di messaggi : 77
Località : Roma
Occupazione/Hobby : Informatica, Auto e moto, Audio
Provincia (Città) : :)
Impianto : Amplificatore S.M.S.L. SA-36 ( TA 2024 ) Alimentatore Pincellone + Diffusori KEF Coda 7 + DAC DAC DIR9001 PCM1793 OPA2134 by S.M.S.L. + Musiland Monitor 02 US
http://www.marcobrogi.com

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 11:55
Asio4all vede la scheda come Sb Live! ( quando avevo i driver proprietari installati...ora che li ho tolti e ho messo i kx non ho provato. )
Quindi leggendo quanto scritto sopra visto che esistono i kx fatti apposta per la mia scheda dovrebbe esser meglio usare proprio questi driver o sbaglio?
avatar
wasky
Moderatore di sezione
Moderatore di sezione
Data d'iscrizione : 03.07.09
Numero di messaggi : 9229
Località : Roma
Occupazione/Hobby : Fancazzista Serio
Provincia (Città) : Come il fiore del ciliegio è il migliore tra i fiori, così, il guerriero è il migliore tra gli uomini
Impianto : Amplifon
http://www.kitaudiopro.com

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 12:04
@brasa ha scritto:Quindi leggendo quanto scritto sopra visto che esistono i kx fatti apposta per la mia scheda dovrebbe esser meglio usare proprio questi driver o sbaglio?

Se sei su XP si ma, se usi Seven potresti usare le API con i WME ufficiali Smile

_________________
"Sentire non è altro che una facoltà permessa da uno dei nostri cinque sensi ma ascoltare è un'arte."   Frank Tyger
avatar
brasa
Interessato
Interessato
Data d'iscrizione : 01.01.11
Numero di messaggi : 77
Località : Roma
Occupazione/Hobby : Informatica, Auto e moto, Audio
Provincia (Città) : :)
Impianto : Amplificatore S.M.S.L. SA-36 ( TA 2024 ) Alimentatore Pincellone + Diffusori KEF Coda 7 + DAC DAC DIR9001 PCM1793 OPA2134 by S.M.S.L. + Musiland Monitor 02 US
http://www.marcobrogi.com

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 12:07
Sono su Xp Wink
avatar
wasky
Moderatore di sezione
Moderatore di sezione
Data d'iscrizione : 03.07.09
Numero di messaggi : 9229
Località : Roma
Occupazione/Hobby : Fancazzista Serio
Provincia (Città) : Come il fiore del ciliegio è il migliore tra i fiori, così, il guerriero è il migliore tra gli uomini
Impianto : Amplifon
http://www.kitaudiopro.com

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 12:57
@brasa ha scritto:Sono su Xp Wink

Perfetto quindi puoi ottimizzare con cMP + Cplay Wink e integrare la Shell e minilogon

http://www.nexthardware.com/forum/cmp-cmp-cplay/

_________________
"Sentire non è altro che una facoltà permessa da uno dei nostri cinque sensi ma ascoltare è un'arte."   Frank Tyger
avatar
brasa
Interessato
Interessato
Data d'iscrizione : 01.01.11
Numero di messaggi : 77
Località : Roma
Occupazione/Hobby : Informatica, Auto e moto, Audio
Provincia (Città) : :)
Impianto : Amplificatore S.M.S.L. SA-36 ( TA 2024 ) Alimentatore Pincellone + Diffusori KEF Coda 7 + DAC DAC DIR9001 PCM1793 OPA2134 by S.M.S.L. + Musiland Monitor 02 US
http://www.marcobrogi.com

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 13:05
Ora gli do uno sguardo ma a quanto ho capito la mia scheda non è compatibile con i file a 24bit...con gli asio4all però funzionava tutto boh??
Sto uscendo pazzo con questa scheda.
avatar
brasa
Interessato
Interessato
Data d'iscrizione : 01.01.11
Numero di messaggi : 77
Località : Roma
Occupazione/Hobby : Informatica, Auto e moto, Audio
Provincia (Città) : :)
Impianto : Amplificatore S.M.S.L. SA-36 ( TA 2024 ) Alimentatore Pincellone + Diffusori KEF Coda 7 + DAC DAC DIR9001 PCM1793 OPA2134 by S.M.S.L. + Musiland Monitor 02 US
http://www.marcobrogi.com

Re: Latenza...non riesco a capire!!

il Mar 1 Mar 2011 - 13:28
Ma visto che ho un Dac esterno con entrata Coax e Toslink posso comprare qualcosa per bypassare la scheda audio?
Vedere l'argomento precedenteTornare in altoVedere l'argomento seguente
Permesso di questo forum:
Non puoi rispondere agli argomenti in questo forum